-   Linux - Software (
-   -   Suse 7.1: Dark screen after reboot (

luzius 02-19-2001 10:00 AM

I have a new double Pentium PC: MSI 694D Pro board, Geoforce 2MX video card, Adaptec SCSI card 29160 and one IBM hard disk, one Maxtor hard disk with UDMA 100.

After first steps of installation, system asks for a reboot. After some boot actions, instead of a login prompt, I get not video signal at all. No reaction on any keyboard key.

If I install "minimum system", I'm able to get a non graphical login prompt by pressing "Alt F2". Xfree86 configuration is not possible.

Can anybody give help? Windows 2000 is running on the system!


KevinJ 02-19-2001 04:21 PM

No X?
You say configuring XFree86 is not possible? What do you mean? Have you tried running Xconfigurator? Choose conservative settings to start if you do.

After doing your normal full install.. boot into single user mode using "Linux single" at the LILO prompt. Edit /etc/inittab to change the default run level to 3.

Reboot normally. You should get a fully functional Linux install but without X-Windows. Try running Xconfigurator as suggested above, then try 'startx'. You will be able to see why its not starting. It could be anything from trying to use too many colors to problems with the X-Font server.

trickykid 02-19-2001 04:35 PM

First off, don't try Xconfigurator if your running SuSE, it doesn't know what the hell that is. And also, after the install, your getting to a login prompt, disregard the runlevel too, you don't have to go into single user mode.
After you install the minimal install, this is what you want to check, first try this at the bash prompt:

# Xf86Config
This is case sensitive in Linux so make sure you type what is caps in caps.

If it doesn't find that, cd into your /etc directory and do a ls.
If the minimal install installed the XFree86 files, you should find a /X11 directory. Or you can do this to locate:
# locate X11
at the bash prompt.

We'll go from there and see where that takes you. Holler back if you need additional help.


trickykid 02-19-2001 04:38 PM

Oh, if the Xf86config does not work you could also try this:
# SaX

This is a SuSE specific configuration program for X windows too that uses the default setup of the XFD86_VGA16 server.

Hope this helps in anyway, if not, let us know.

KevinJ 02-19-2001 04:52 PM

no Xconfigurator?
My mistake.. not sure.. but if Xconfigurator is not present then it might only be on Redhat and not SUSE, but I don't find an 'Xf86Config' on my system either.

Tricky, are you referring to the program 'xf86config' as opposed to the the config file 'XF86Config'?

Luzius, Tricky may be right. You may have to run 'xf86config' which is text based to set up X windows. Or you can use the graphical SUSE utility that he is referring to as well. But, and I am only guessing, if your system was setup incorrectly during the SUSE install with no intervention from you, then it will probably set it up wrong again. With that in mind, text based 'xf86config' might be your best bet. At any rate, if you only get a blank screen and no keyboard response on a normal boot, you will have to go 'single user' to get to where you can type anything.

trickykid 02-19-2001 05:24 PM

Okay, yeah, I got confused there myself thinking of the file instead of the program, you need to try xf86config for the configuration of X, not Xf86Config, just think all lowercase.
But I would seriously try SaX, it will be a graphical setup compared to the text based xf86config will give you.
And yes, if your getting no login prompt after the bootup, then you will want to try running in runlevel 1. Sounds to me, your system is trying to boot into X to login, and by you switching terminals, yes that would get you to the bash prompt in another terminal session. Runlevel 1 will prevent that from happening when you first boot up.

Yeah, Xconfigurator is only with RedHat that I know of now, Mandrake use to have it I think, but I know it uses Drakconf now.

luzius 02-28-2001 03:57 AM

Thank you everybody for your reply!
I tried SAX before already, but it freezes instantly!
I did configure my video card with Xfree86. I could not find my Geoforce2 card, but some similar staff (e.g. TNT2).
Nevertheless, if I try to execute startx, I get error messages.

I then tried a mandrake distribution, and here everything works fine. So I will not put any more time in Suse!

stanlo 09-01-2003 09:40 AM

Hi luzius.

I have been battling with X on suse 8.2. This what helped me fix my problem. Run as root :"sax2 -V 1024x768@60".
Change the resolution and frequency to suite your monitor.

Good luck


All times are GMT -5. The time now is 09:57 PM.