-   Linux - Software (
-   -   Suse 10.1 freezes randomly (

preeth26 06-07-2006 01:25 PM

Suse 10.1 freezes randomly
Hi there
I hope someone can help, I recently upgraded from Suse 10.0 to Suse 10.1 on my HP Pavilion dv5000 with a 64 bit AMD Turion processor. After the upgrade the entire laptop freezes randomly during normal use, for no apparent reason. I am unable to figure out why this happens. Each time I am forced to power down completely in order to get the laptop running again. I did not have the same problem when running Suse 10.0 and I am now dual booting Suse 10.0 with Suse 10.1. Suse 10.1 seems to work fine for most part but is extremely frustrating when it locks up suddenly, leaving me with no mouse or keyboard. Any help will be greatly appreciated.


Caeda 06-08-2006 10:01 PM

They did make some changes to the acpi settings which actually fixed my notebook which wouldnt run 10.0 at all...

You are running the 64 bit version and have applied all of the available updates in the 10.1/update and packman update sites?

mykrob 06-09-2006 02:10 AM

Suse 10.1 locked up a great deal on my laptop too, an HP Pavilion ze2308. I tried numerous new distros, and Suse 10.1 wasthe only one that exhibited this behavior, leading me to belive there is a problem with Suse 10.1 While it runs fine on my desktop computer, it sucks on the laptop..

Ended up going with Mepis 6 beta 5, it is much more stable, plus the debian repositories gives it much more ready-to-install software in the package manager.. Not to mention, getting 3D accel. on the ati card is just two click aways :)

preeth26 06-09-2006 09:53 AM

Suse 10.1 freezes randomly
Yes, I have. In fact I was able to run Suse 10.0 after installing it with noapic option but with Suse 10.1 even this was not necessary, it installs perfectly! Yet it freezes randomly for no apparent reason at all at the most inconvenient times! Any ideas as to what might be causing this?
Thanks for your help.

Caeda 06-13-2006 04:47 PM

What happens if you turn of acpi in 10.1?
If it still freezes at least you know it's not acpi. If it doesnt freeze you know the problem and can check things like the acpi power controls. I'd suggest looking to see if you have any timers set by default to do things like auto-throttle, power management, auto hybernate. And other things that turn themselves on after a time period. Maybe kill all the screensaver settings too just in case :)

docbill 08-22-2006 01:16 PM

This happens to me too. Through the process of elimination, I have determined that this is not caused by: X11, KDE, GNOME, or the powersaver. It seems the freezes happen most often when running GNOME, but I have seen the freezes even when booting to runlevel 3 and using strictly console commands.

I thought maybe the SuSE kernel patches where to blaim, so I tried a vanilla build of 2.6.17-6. At first it seemed to solve the problems, but eventually it froze as well. When I rebooted the second time it froze almost right away. So I can rule out the kernel patches as the cause. I am now trying a compination of the newer kernel without powersaved running. However, I fully expect that is not the solution either.

Any suggestions what I else I can try checking? Nothing is logged in the /var/log files indicating what is causing the error. It the freeze just consists of keyboard and mouse stop responding. Sometimes the screen is blanked, sometimes it isn't. All hard drive activity also stops. Pressing the power button has no effect. If I check the logs after rebooting, nothing is logged after the start of the freeze, indicating the system truly is frozen. The freeze happens most often when running GNOME, or when running Yast2 in console mode. The freeze happens less often if I have top running in a console window... Nothing seems to completely prevent freezes, and nothing always causes them.

SuSE Linux 10.1 x86_64: On a Emachines H6415 using NVidia GForce 6600, RS480M-IL, 1GB Ram, SATA drive.


Richard Rahl 08-22-2006 08:46 PM

Do you use Ndiswrapper? This happened once or twice on my Gatewat 7510GX with 10.1, but only after I installed ndiswrapper, which I read can sometimes cause lockups.

Pcghost 08-22-2006 08:58 PM

Are you using the latest nvidia-glx driver? I am having the same issue with my desktop machine (Athlon X2 4200 & 2xGeForce 6800 XT). I cannot use the nvidia driver without it locking up the machine. SuSE 10.1 did the same. Switching to the nv driver fixes it, but without 3D that is hardly a fix.

preeth26 08-23-2006 06:31 PM

Suse 10.1 freezes randomly update
Hi everyone
Thanks for all your responses and suggestions. I was initially inclined to troubleshoot my installation of Suse 10.1 in accordance with the various suggestions. However, I realized that the freezes were continuing while I was trying one thing or the other and I finally gave up trying to fix it because i was not sure if I would be damaging my laptop by repeatedly shutting down using the power switch. I am now using Novell SLED in evaluation mode and it seems to be running okay with no freezes. However I did briefly try Suse 10.1 Alpha 2 before installing SLED and that too seemed to run fine without any freezes. I would have liked to try and fix the problem but for the fact that my expertise is fairly limited and also because I was not sure if I would damage my laptop in the process.

My eventual goal is to install some source based distribution like Gentoo but for the moment I am running Novell SLED and Ubuntu 6.10 Edgy EFT without any problems, even though some of the applications are not working from the graphical menus.

I am somewhat surprised that Suse seemingly has such a serious problem on some hardware and wonder if the problem is specific only to some laptops or to a variety of equipment.
Thanks again

docbill 08-24-2006 09:11 AM


Originally Posted by Pcghost
Are you using the latest nvidia-glx driver? I am having the same issue with my desktop machine (Athlon X2 4200 & 2xGeForce 6800 XT). I cannot use the nvidia driver without it locking up the machine. SuSE 10.1 did the same. Switching to the nv driver fixes it, but without 3D that is hardly a fix.

When I used the ATI driver, it definitely caused freezes. However, those freezes where always predictable and repeatable. When I uninstalled the ATI software when I installed the GeForce 6600. I have ruled out the nvidia drivers as a possible cause, because they are not loaded when I boot to run level 3 and operate strictly in console mode.

I think I might have been premature to rule out powersaved. I had configured SuSE not to load any of the drivers, but still SuSE froze. However, I had not actually stopped the powersaved daemon. I started to try that yesterday, but then my wife needed me to boot to Windows to test a webcam. I will try again today after I finish the work I have running under windows.


docbill 08-25-2006 03:35 PM

The problem was dynamic cpu frequency


in /etc/powersave/cpufreq

and then restarting powersaved solved the problem.


sven.bauer 08-26-2006 06:32 PM

What do you mean by saying "restarting powersaved"? I am having the same problem and would like to follow what you suggested...


preeth26 08-26-2006 07:15 PM

Thanks for your suggestion
Thanks docbill, I went back and reinstalled Suse 10.1 today and made the change. Hope it works! I guess restarting the powersave daemon can be done from Yast...

docbill 08-27-2006 12:12 PM


Originally Posted by sven.bauer
What do you mean by saying "restarting powersaved"? I am having the same problem and would like to follow what you suggested...


Either reboot or as root run:

/etc/rc.d/powersaved stop
/etc/rc.d/powersaved start

If you still have freezes, you might just try leaving the powersaved daemon stopped to see if this daemon is causing the problem.

preeth26 08-27-2006 10:28 PM

No luck with that fix!
Hi docbill
I did not have any luck with that fix on my laptop. Suse 10.0 ran fine, so also did Novell SLED 10.0. I guess I will keep Suse until I figure out a way to install Gentoo or Arch Linux on my computer. For the moment I installed Kanotix 64 bit today as a dual boot and it installs and runs fine with all the hardware recognized properly. If you can think of any other fix please let me know.

Thanks again for your efforts and help.

All times are GMT -5. The time now is 10:42 PM.