-   Linux - Software (
-   -   Sun Studio - openSUSE (

mrstarware 12-26-2009 10:11 PM

Sun Studio - openSUSE
Hi, I just installed Sun Studio on openSUSE 11.2

The problem is that it's not showing up in the applications list. Also I tried to run the installer a second time and it told me everything was already installed. I tried %sunstudio but that just told me it didn't recognize the command.

Thank you for your help.

bigrigdriver 12-27-2009 06:43 PM

Both KDE and Gnome have menu editor tools that you can use to add the application to the main menu.

In re the command line not working, I'll assume you are fairly new to command-line operations, and offer this advice:
If the executable you want to start from the command line is in your path, it should work as you tried it. If it is not in your path, it won't work as you tried it. You need to do one of two things:
1) cd to the directory which contains the executable, and issue the command this way: ./sunstudio.
The leading ./ tells the shell "in this directory".
2) from anywhere in the directory tree, issue the command giving the full path to the executable. For example, if the executable in in /usr/local/bin, you give the command as: /usr/loca/bin/sunstudio.

If you don't know where the executable is, issue this command: which sunstudio. The return should be the path to the executable.

mrstarware 12-27-2009 08:05 PM

The problem was that I couldn't find the executable file. Which I now (feeling like an idiot) realize is at "root"->opt->sun->sunstudio12.1 (after this I got lost)->bin->sunstudio (the shell script).

thank you. :redface:

All times are GMT -5. The time now is 10:42 PM.