-   Linux - Software (
-   -   Successfully built Linux for BeagleBoard with OpenEmbedded what? (

leiphasw 10-30-2010 05:51 PM

Successfully built Linux for BeagleBoard with OpenEmbedded what?
After much frustration, I finally have successfully built a full OpenEmbedded Linux distribution from the source and OE recipes. (Linux box ran for 14 hours!) Anyway, I somewhat randomly picked the MLO, uboot.bin and uImage files from the rather large collection that showed up in the build output file for my BeagleBoard. (I have both BeagleBoard C4 and XM, but I am running these test files on the C4 because it uses standard size SD cards rather than the MicroSD that the XM board uses which I only have one of.)

It boots up to where it loads and decompresses the Kernel... then just sits there blinking one of the board LEDs. How do I get it to start up an X window session to go to the attached monitor?

I have tried looking at boot.scr and user.scr files on working systems and have modified them for my use to no avail. The prebuilt images that I have downloaded and run correctly all use a ramdisk image which I don't have. I can't see what is in them to try to copy that functionality.

I know I could just use a prebuilt image, but I want to build my own from source for the project that I am working on that needs to have much of the typical content bulk removed. I have tried using Narcissus to build an image, but that typically doesn't work. I have started Narcissus builds at least 6 times and only one ever completed after about 6 hours and then the system halted while trying to download the image.

If I knew a way to get back to the Narcissus image(s) that presumably built after leaving the build page after waiting up to 24 hours, that would probably be good enough, but there doesn't seem to be a way to do that.


Thanks in advance for anyone who has a clue what I should do.

leiphasw 10-31-2010 02:02 PM

I worked around this by just using the downloaded image from and then overwriting the uImage file with mine. That works good enough for now and it loads my kernel.

All times are GMT -5. The time now is 06:12 PM.