Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 05-19-2003, 05:02 PM   #1
Registered: May 2003
Posts: 30

Rep: Reputation: 15
stupid gdm

i need to install the new nvidia drivers and when i run the script it tells me i cannot continue because i have a instance of X running. well i have logged out of kde. but stupid gdm is running. so the install will not continue
i really dont even care for gdm. i can type startx myself and sometimes i when i boot i really dont need to go to x.
unfortunately i picked to boot to x when i was installing redhat8.0. now i cant get rid of gdm. i tried killall but it just restarts another one. any suggestions?
Old 05-19-2003, 05:07 PM   #2
Registered: Feb 2002
Location: Fairfax, VA
Distribution: RedHat 8, Mandrake9.1, Slack9
Posts: 456

Rep: Reputation: 31
if you want to boot to CLI by default,

open '/etc/inittab' file and change the line which says


to default:3:.....

and reboot

or you can do a 'telinit 3' or 'telinit 1' to goto to CLI mode or single user mode and then you can install the driver

Last edited by manthram; 05-19-2003 at 05:08 PM.
Old 05-19-2003, 05:08 PM   #3
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
As root, telinit 3, will disable X.

To boot into test mode, edit /etc/inittab and change the line
Old 05-19-2003, 05:12 PM   #4
Registered: May 2003
Posts: 30

Original Poster
Rep: Reputation: 15
thanks guys thats what i call speedy services with a smile
Old 05-19-2003, 06:13 PM   #5
LQ Guru
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Whaaa? No need to reboot. Switch to VT1 by pressing ctrl-alt-f1, log in as root and run

/sbin/init 3

then run the driver installer, and when done:

/sbin/init 5

nothing to it. No need to reboot or edit the inittab (a dangerous file to mess up)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
what is /etc/x11/gdm/gdm.conf ? Floreen Linux - Newbie 2 04-30-2007 01:22 PM
Stupid, stupid question; I lost Klaptop. :( Surfrider Slackware 2 08-31-2005 10:12 PM
Stupid Dumb Stupid Question... drigz Linux - Software 3 09-23-2004 04:09 PM
stupid stupid newb ? what to use instead of xconfigurator h00ligan Fedora 3 01-25-2004 10:51 PM
gdm overwrites /etc/gdm/Session/fluxbox _flaab_ Mandriva 0 12-21-2003 11:58 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:08 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration