LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Strangest FTP error on RHEL5. gFTP works. RHEL4 works too. (https://www.linuxquestions.org/questions/linux-software-2/strangest-ftp-error-on-rhel5-gftp-works-rhel4-works-too-634255/)

GuitsBoy 04-09-2008 03:35 PM

Strangest FTP error on RHEL5. gFTP works. RHEL4 works too.
 
Heres the deal. Just did a hardware / OS upgrade on one of the servers we have here. We have a couple of scripts that ftp files to some sort of EDI processor. The FTP has been failing since we cut over to the new box.

CLI from RHEL5 does not work. The client just hangs.
GUI from RHEL5 works as it should.
CLI from RHEL4 works as it should.

We have tried command line FTP from a number of RHEL5 and CentOS5 boxes, and none of them successfully connect. They all just hang.

Ive tried stracing it, but I dont understand very much of the output, however it looks like it just hangs, where as the RHEL4 boxes make it past that point.

I know its not a problem with the IP address, or a firewall issue because the GUI (gFTP) works as it should.

Ive even gone so far as to install yafc, which will not connect, nor will it connect using a RHEL4 box as an ftp proxy.

Im at my wits end. I just can't come up with a viable workaround...

GuitsBoy 04-10-2008 08:29 AM

After contacting redhat support and going through a few things, they suggested this solution:

Execute below command and then try to ftp to the server from RHEL5.
# echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

If this works you can make the settings permanent by adding line to
/etc/sysctl.conf as below.
net.ipv4.tcp_window_scaling = 0

It is kind of a "the internet is broken" issue. Starting with the 2.6.7
kernel, TCP Window Scaling was enabled. This is defined in RFC 1323, penned
back in 1992. Apparently, some parts of the internet are still broken.

Here's some further reading on this:

LWN article:

http://lwn.net/Articles/92727/

and the "discussion" from LKML:

http://lkml.org/lkml/2004/6/29/85

Props to redhat for a quick solution!
Thanks!


All times are GMT -5. The time now is 09:12 PM.