LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-26-2002, 03:51 AM   #1
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Rep: Reputation: 30
Post Strange problem with X and new kernel.


Hey all!
I decided to upgrade to a newer kernel since my previous one (custom 2.4.18), started acting up. So I first I built a fresh 2.4.19 kernel from scratch, and *everything* worked great.

I have an nvidia card, so first thing I did after the fresh kernel started was to 'make clean, make install' the nvidia kernel module. That went great as well.

I fired up X, and it worked as usual, but as soon as I exit X, the box locks up HARD. I thought maybe its the nvidia driver, so I set XF86Config to use the builtin 'nv' driver instead. Same result.

Then 2.4.20 released, so I downloaded it, and build it, again from scratch.. Same result

Anyone know if I missed something vital in my kernel config?
Thanks for reading

RefriedBean
 
Old 12-27-2002, 05:26 AM   #2
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Original Poster
Rep: Reputation: 30
I decided to go back to 2.4.18 in while I wait for Slackware 9.0. This seems to resolve the problem

RefriedBean
 
Old 12-27-2002, 06:40 AM   #3
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Strange.....try building a 2.4.20 kernel with the .config from slack 2.4.18.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.8.1 strange kernel compile problem Haniblectre Slackware 5 02-03-2005 05:25 PM
Strange Kernel Keyboard Problem dgeronimo Linux - Software 1 12-25-2004 11:06 PM
Strange problem regarding ethernet in kernel 2.6.9 bilalmughal Slackware 0 11-28-2004 07:45 AM
Strange Apache problem after upgrade to 2.6 kernel sal_paradise42 Linux - General 7 06-08-2004 05:56 PM
Strange network problem after compiling new kernel.. katana Linux - General 1 12-19-2002 10:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration