LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-24-2016, 05:16 PM   #1
oneleaf
LQ Newbie
 
Registered: Aug 2014
Posts: 12

Rep: Reputation: Disabled
Strange output on rxvt-unicode?


Hi there,
Got a strange issue with rxvt-unicode-256colors (from the Ubuntu 16.04 repository). I am running a gsutil rsync command (Google Cloud SDK command) that outputs a progress indicator correctly in xfce-terminal and gnome-terminal. However, when using urxvt, it spits out a lot of new-lines rather than keeping the progress on one line as it is processing.

Please see attachment of what it looks like. I got some feedback from another forum that suggests it is a bug in the gsutil program, which seems to be the case. Just wanted to see if there were any ways urxvt can deal with this undesirable behavior, or whether I need to wait for Google to fix this bug? Any feedback or suggestions is appreciated! Thanks.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-Urxvt.jpg
Views:	21
Size:	48.4 KB
ID:	23102  
 
Old 09-25-2016, 09:28 PM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Looks like you're having a linefeed where it would otherwise carriage return. I normally get this with ffmpeg when the xterm (urxvt) isn't wide enough.

$ echo $COLUMNS

My wm lets me do a key combo to max the term across the width, which normally keeps it from scrolling further. Otherwise it might be doing \n instead of \r. If that's the case you might be able to use sed to change it.

$ $(whatever generates this) 2>&1 | sed 's/\n/\r/g'

Or I could be way off. And that might make other things behave worse than what it might fix.
 
Old 09-26-2016, 02:05 AM   #3
oneleaf
LQ Newbie
 
Registered: Aug 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hmmm, interesting. Making the window wider fixed my problem. Will look into your suggestions more when I have time this week and see if I can figure out how to fix this! Thanks a lot for the response!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RXVT-unicode, strange behavior in Debian SID Vizaa Linux - Software 1 10-24-2012 09:48 AM
[SOLVED] Problem displaying Unicode special characters in Urxvt/rxvt-unicode terminal shahinism Slackware 4 10-22-2012 03:08 PM
rxvt-unicode hacking mkoco Slackware 18 06-07-2011 10:27 AM
[SOLVED] TERM=rxvt / rxvt-unicode and ctrl-L irb Slackware 10 06-09-2010 05:09 AM
problem with rxvt-unicode corbis_demon Linux - Software 0 11-27-2007 10:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration