LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-04-2003, 09:29 PM   #1
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Rep: Reputation: 15
Strange login?!


During Suse 9 installation I created 1 regular user "test".
After restart Linux is loaded without asking user name and password.
"Logged" user is "test". After log off I am getting promt. So I can login
as root or as test user.
If I restart pc there is no login promp. It is just like Windows3.1
goes directly to my nice desktop.
I never saw this effect with other distros. By the way the same Suse 9
on laptop always give a login box.
I checked all options in Yast. And didn't find any option for enabling
login without password...
What it may be?
Thanks.
Michael.
 
Old 12-05-2003, 02:48 AM   #2
ganja_guru
Member
 
Registered: Dec 2003
Location: Chennai, India
Distribution: Arch Linux 0.7
Posts: 393

Rep: Reputation: 30
ok i dunno how it is in suse but i guess its the same for all..

i assume u are now using a run level of 5, which is the graphical login, and i figure that what u want to use is run level 3 , which asks u to login and then type 'startx' to ..well...start X

simple...all u have to do is edit ure iniittab file

type

pico /etc/inittab


this is my file...i run slack..

# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:


note : in slack, the graphical login is run level 4 and not 5...im not exactly sure how it is in suse...

in ure inittab, its probably set to id:5:initdefault: or something similar...just change to id:3:initdefault


tell me if it worked...
 
Old 12-05-2003, 02:49 AM   #3
ganja_guru
Member
 
Registered: Dec 2003
Location: Chennai, India
Distribution: Arch Linux 0.7
Posts: 393

Rep: Reputation: 30
please do a search on the board for this kinda stuff man, its there everywhere...
 
Old 12-05-2003, 02:08 PM   #4
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Original Poster
Rep: Reputation: 15
I don't want to go to level 3
By default it's run lever 5.
What I'm asking. Why there is no login box. I think on XP Home edition
this is default option. Just not to bug home user with password.
So on Suse may be some "switch" for on/off this option.
All the other topics about login problems on forum are not related to my question.
Thanks.
Michael.
 
Old 12-05-2003, 02:20 PM   #5
amos
Member
 
Registered: Dec 2002
Location: Manchester, UK
Distribution: LMDE
Posts: 224

Rep: Reputation: 30
Try opening the login manager under KDE, and altering the choices there.

Whether Suse does it deliberately or not you have somehow chosen to log in automatically, you can either open the login manager itself or the control centre and select the login section, somewhere in there is a convenience section with a checkbox to do with logging in automatically.

Cheers
Amos
 
Old 12-05-2003, 02:27 PM   #6
Eugene
Member
 
Registered: Nov 2003
Distribution: SuSE 9.0! and loving it!
Posts: 86

Rep: Reputation: 15
yap

Wierd problem, happend to me too.
You reboot, and it goes stright to gnoom right? not asking for username/pass or anything...

well you don't need to go to runlevel 3 (which by the way there is a VERY easy way of doing. when the boot loader loads, write linux 3 and choose linux... it will boot into runlevel 3)

all you need to do is make another user.
You don't need to USE that user... just ignore it.


Go to: Yast>>Security and Users>>Edit and Create users...

Make a new user, with a password like 12345.
Hit ctrl+alt+backspace... and there you have it!



(couldn't find a diffrent fix for this, if you do find one please tell me...)
 
Old 12-05-2003, 07:11 PM   #7
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Original Poster
Rep: Reputation: 15
thanks for answers guys
since I didn't find any option in Yast user configuration and security
probably the best choice will be create new user 500 (or 501 don't remember who is first) and destroy first one.
I will do it Monday. I shuted down suse box at work.

Still I think that there must be an option for disabling loginless password.

Thanks.
Michael.
 
Old 12-06-2003, 02:43 AM   #8
iTux
Member
 
Registered: Dec 2003
Posts: 33

Rep: Reputation: 15
Hi,

First the solution may depend if you are using xdm, kdm or gdm.
Any of these provide the login window but kdm will have a KDE look and gdm a gnome look.

I'm on Debian, but if you look in /etc/gdm/gdm.conf, you will see there is an option to autologin. There is probably a similar option somewhere for kdm if you are using it.

Another cause could be that instead of starting on of the login window programs, it starts X with
the startx command but this is unlikely.

You can use ps to check if one of xdm, kdm or gdm is running and if yes to know which one to start / configure.

curly:~> ps aux | grep dm
root 352 0.0 0.3 10832 992 ? S Dec06 0:00 /usr/bin/gdm
root 357 0.0 0.4 11168 1172 ? S Dec06 0:00 /usr/bin/gdm
root 365 4.3 8.9 67020 22852 ? S< Dec06 37:20 /usr/bin/X11/X :0 -deferglyphs 16 -nolisten tcp -auth /var/lib/gdm/:0.Xauth vt7
curly:~>


iTux

Last edited by iTux; 12-06-2003 at 02:44 AM.
 
Old 12-06-2003, 07:26 AM   #9
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Original Poster
Rep: Reputation: 15
Thanks. I will check it Monday. And let you know.
Sure that to find "right" solution is better than delete and recreate user.
 
Old 12-06-2003, 06:51 PM   #10
mla
Member
 
Registered: Sep 2003
Location: Canada
Posts: 86

Original Poster
Rep: Reputation: 15
amos is right.
Very simple
I checked suse9 on my laptop that not doing this "weird" login.
The exact way is:
Control Center - System Administrator - Login Manager - Convenience tab.

So it's for convinience .
Looks like on my work system I didn't uncheck
this option during installation. And forgot that it exist. Because on laptop
I probably unchecked it during install ( I installed it late night ).

That is it.
Thanks to all.
 
Old 12-10-2003, 10:24 AM   #11
Eugene
Member
 
Registered: Nov 2003
Distribution: SuSE 9.0! and loving it!
Posts: 86

Rep: Reputation: 15
oh!

And I thought it was a bug!

*off to fix this*


 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange X login problem. rsamurti Slackware - Installation 4 11-08-2005 02:45 AM
Strange login Warning JrLz Slackware 10 01-24-2005 05:41 AM
strange error, cant login but su - works ! qwijibow Linux - Software 1 08-23-2004 10:47 AM
Strange re-login behavior NickC Mandriva 9 07-20-2004 12:20 AM
strange bash login error figmentium Linux - Newbie 3 08-11-2003 05:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration