-   Linux - Software (
-   -   Strange...can't share usb printer connected to xp pc (

vatman 10-30-2005 09:42 AM

Strange...can't share usb printer connected to xp pc
I use a slackware Laptop connected to a pc with xp. I JUST want to print to the usb printer connected to the xp pc...

Samba works perfectly, i can share files and stuff but no printing..

The strange thing is that for once i succeded printing with cups from the slackware laptop but after restart ...nop

These are my steps (This is what it worked for just once..!!):

On WIN pc:

1) I go to "Start" --> "Settings" --> "Control Panel" --> "Add/Remove Programs" --> "Add/Remove Windows Components".
I click "Other Network File and Print Services", then click "Details"
and i select the "Print Services for UNIX" check box, then click "OK"

2) I open Network Connections
Right-click on the appropriate network interface and i select Properties.
I click on the "Advanced" tab and the "Settings" button to open the firewall settings.
On the firewall settings, i click on the "Exceptions" tab, then the "Add Port" button.
I name the service: LPD, and i enter port number 515.

3) I share the printer (name of shared printer: hpdeskjet) and i disable Norton Internet Security just for sure..

On SLACK pc:

4) First i configure samba (smb.conf).
This is what i get after running testparm:

:/# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Processing section "[tmp]"
Loaded services file OK.
Press enter to see a dump of your service definitions

# Global parameters
workgroup = MYGROUP
server string = Samba Server
log file = /var/log/samba.%m
max log size = 50
dns proxy = No

comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

path = /tmp/samba
read only = No
guest ok = Yes

5) I open cups and i add my hp deskjet 5150 printer (printer works fine when
Then i select "LPD/LPR Host or Printer" as the Device and i enter the Device URL lpd:// ( is xp pc)
(When i tried Windows Server via Samba and for url smb:// or something like smb://username:password@ it didn't work at all..)

With LPD as Device and with the lpd url i was able just for once to print a test page and other stuff...until i restarted..

So what's wrong??

Do i have to modprobe anything or run any extra command?

Network with cross cable is fine. I can ping both sides. I can share files in /tmp/samba but i cannot print from the slackware box....

Any ideas???

Thanks in advance.

steve1972 11-01-2005 09:31 AM

Samba or LPD
CUPS can print to Windows servers in one of two ways:

1) Samba
2) LPD

From the CUPS website ( I found these two articles detailing how to do that:

Printing to Windows Server with Samba

Printing to Windows Server with LPD

Let me know how you do.

vatman 11-02-2005 06:50 PM

Thanks for the answer steve!
The article with the LPD really helped!

I just had to enable the "TCP/IP Printing Server" at the services in the xp pc and the printer started printing!! (The option with the "Print Services for UNIX" that i mentioned before is also necessary but the one with the lpd port 515 is finally useless)

Thanks again!!

All times are GMT -5. The time now is 03:09 PM.