-   Linux - Software (
-   -   strange boot behaviour with lilo... (

supervillan 06-02-2004 11:43 AM

strange boot behaviour with lilo...
Normally when I boot, lilo comes up (it's installed in the MBR) asking me weather I want Linux or Windows. I just tried to boot from a knoppix cd-rom too see if it works since I want to use linux at school, but even though I have set the booting sequence in bios to be cd-rom, hdd and then floppy it didn't boot. I know I have booted from cd-roms before and they worked (but that was before I installed linux) so I have set the bios to boot only from cd-rom (I disabled the other options). I guess that if the cd-rom wasn't bootable or if the cd-rom couldn't boot I should have received an error, but a strange thing happened: it booted from the hdd again. Why did this happen? :scratch:

Inexactitude 06-02-2004 12:01 PM

Well, I can't exactly help you here, but I can tell you that the problem has nothing to do with lilo. It's definetly something in your bios. Post your motherboard type and bios version and maybe somebody who is familiar with it can help you out.

r_jensen11 06-02-2004 02:56 PM

Do you have more than one CD-ROM? I can only boot off of one of my two CD-ROM drives. My system is set up like this:

hda hard drive w/ windows stuff
hdb hard drive w/ windows stuff
hdc dvd-rom drive
hdd cdrw drive
hde hard drive w/ linux (connected via PCI card that gives me two more IDE cable slots)
And for some reason, I can only with CD's from hdc, not hdd. If you have more than one CD-ROM drive, then try putting the disk in the other cdrom drive. Also, if you have a boot menu before LILO loads, (for me it's either F10 or F12, I forget which) you can tell it to only boot from the CD-ROM or Floppy for that one time, not having to mess around with the bios. Then if it can't boot from the CD-ROM, it'll let you try again, so put the CD into the other CD-ROM drive and try again. Unless you flashed your BIOS or something, I don't see why you shouldn't be able to boot from CD-ROM at all. Have you tried booting off of a slackware CD that you installed from?

supervillan 06-03-2004 12:34 PM

I tried to boot from the same CD at school and it didn't work. It seems that the CD isn't bootable. Anyway it is still strange that by setting the cd-rom as the only boot device it still boots from hdd. I think that Inexactitude is right: It's something with the bios. My motherboard is a Gigabyte GT-7VT600. If anyone knows anything about bugs with this motherboard please notify me.

PS I have only one cd-rom.

All times are GMT -5. The time now is 09:21 PM.