-   Linux - Software (
-   -   still having problems with Webmin and apache not working (

blainemiller 07-10-2010 11:38 AM

still having problems with Webmin and apache not working
I entered this same thread several months ago. Still I have no accurate assessment or solution.

My httpd.conf is as follows:

# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition. These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.
Include /etc/apache2/default-server.conf

# Another way to include your own files
# The file below is generated from /etc/sysconfig/apache2,
# include arbitrary files as named in APACHE_CONF_INCLUDE_FILES and
Include /etc/apache2/sysconfig.d/include.conf

### Virtual server configuration ############################################
# VirtualHost: If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
# Please see the documentation at
# <URL:>
# for further details before you try to setup virtual hosts.
# You may use the command line option '-S' to verify your virtual host
# configuration.
Include /etc/apache2/vhosts.d/*.conf

# Note: instead of adding your own configuration here, consider
# adding it in your own file (/etc/apache2/httpd.conf.local)
# putting its name into APACHE_CONF_INCLUDE_FILES in
# /etc/sysconfig/apache2 -- this will make system updates
# easier :)

the vhosts.d directory contains all the appropriate *.conf files.

I continue to be stumped. Any help will be appreciated.

Thanks again for your patience.


paulsm4 07-10-2010 11:52 AM

blainemiller -

1. I did a search ("find other posts by..."), and I can't find any previous posts from you on this question. Ever.
Q: Are you sure your original question actually got posted here?

2. Q: What exactly is the problem?
What are you trying to accomplish?
What have you tried?
What went wrong?
Were there any error messages? If so, please post them.

3. Q: Exactly what Linux distro, kernel version, and Apache version are you running?

Thanx in advance .. PSM

blainemiller 07-10-2010 02:33 PM

Hi back...

I've tried both SuSE 10.3 as well as 11.1 without a difference. I'm currently running 10.3 on one system and 11.2 on a second machine. The primary device I need to get up and running is Linux version Apache is version 2.2.4.

I'm sure I posted the problem here, just not sure when.

The problem is that when I use Webmin to create virtual web sites, the sites are indeed created, however, only the first website is functional. All subsequent sites display the web page of the first virtual server.

I need some way of creating virtual web sites with Webmin that works. I'm pretty sure this is a problem with Webmin and have posted the same question on their site.

The other three questions I believe I answered in the body of my first posting here a little bit ago.

I'm really stymied with this and Webmin and am thinking of building virtual websites manually.

I'd rather use the Webmin gui.

Thanks for your time and consideration.


paulsm4 07-10-2010 06:41 PM

Hi -

For whatever it's worth, I'd strongly urge you to try creating at least one set of virtual hosts manually:

a) Apache *should* work without problem.

b) It's a useful exercise to understand "what's happening under the hood".

c) Understanding the Apache configuration will help your troubleshooting should you ever encounter problems with Webmin ;)

d) Understanding the Apache configuration will help you tweak options that you might need, but that Webmin might not expose for you.

Having said that:

Q: have you tried the VirtualMin plugin for Webmin?

Q: Are you using Webmin merely to *create* virtual hosts, or do you want to use it to administer the entire system?

Q: If the latter, why not configure remote access and use YaST?

I have zero experience with Webmin. I'm learning Plesk at the moment :)

baronobeefdip 07-10-2010 07:12 PM

uninstall webmin and apaches and lets start over

download and install webmin (i always installed it with the tarall but your call there i don't think it matters)
then go into webmin with your favorite browser and on the left side you should see some menus select the last one (un-used clusers) and look for apache web server it should tell you that it isn't installed and provide a link to install it click on it and it should install perfectly

ps: i only tried this in ubuntu so its just a thought i wasn't really fond of suse too many restrictions and some commands aren't there (the make command for instance isn't there and installing it is a real pain i haven't been successful there so i gave up on it perhaps a differemt distro if my method doesn't work out its the easiest way i can come up with)

blainemiller 07-26-2010 01:09 PM


Still struggling here. I indeed re-downloaded webmin and neither the version I had nor the new version has made any differnce. I still can't use webmin to manage/create my virtual websites. Apache appears to get stuck serving the htdocs subdirectory

I've turned on debug on one of the sites, but without me discovering more about apache, I'm pretty stuck.

Any assistance is greatly appreciated.

Thanks for your genius..


blainemiller 07-26-2010 02:22 PM


I removed the Include statement for vhosts.d and I see that the http.conf correctly points to the default web page.

Next, I'm going to ignore webmin and try to manually add the virtual hosts and see how that goes... I'm sorta lost here too, but what the heck, unlike Webmin, at least there's hardcopy and online documentation.

As always, any pointers for either webmin or in how to do this in apache are appreciated.



blainemiller 07-26-2010 03:29 PM

Hello, all...

Here's where I'm at now...

I added the following lines to my httpd.conf file

NameVirtualHost *:80

<VirtualHost *:80>
ServerAlias *
DocumentRoot /srv/www/gtmachining

<VirtualHost *:80>
DocumentRoot /srv/www/patriciaspostcards

When I run httpd2 -S

I get:

httpd2: apr_sockaddr_info_get() failed for gtpam
httpd2: Could not reliably determine the server's fully qualified domain name, using for ServerName
VirtualHost configuration:
Syntax OK

Also, the second web page still seems to point to the first webpage, no matter what I type in for the URL..

Now I'm at the edge of my limit as far as Apache goes...

Any help is appreciated...


PS... I'll try to post the code using the "Advanced" option next time.

blainemiller 07-26-2010 03:55 PM

Next, I changed the hostname on a more permanent basis and cleared the:

httpd2: apr_sockaddr_info_get() failed for gtpam
httpd2: Could not reliably determine the server's fully qualified domain name, using for ServerName


Now httpd2 -S seems to run clean.

httpd2 -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80 is a NameVirtualHost
default server (/etc/apache2/httpd.conf:209)
port 80 namevhost (/etc/apache2/httpd.conf:209)
port 80 namevhost (/etc/apache2/httpd.conf:215)
Syntax OK

However, even after rebooting and restarting Apache, I cannot browse for the second website. I always end up on the default/fist website of gtmachining...

Any help is appreciated.


blainemiller 07-26-2010 05:02 PM

Also, I don't know if this is pertinent or not, but I'm getting 403 errors on one browser, IE8, and no errors on Firefox...


blainemiller 07-26-2010 05:15 PM

Correction... I'm getting 403 errors now from all browsers. I guess Firefox just cached things for a little longer...

Thanks for your reading this and your assistance.


blainemiller 07-26-2010 11:30 PM

Next update... I reverted back to a (saved) older version of httpd.conf and got the duplicating websites back without the 403 errors.

Next order of business is I'm going to try to *revert* the installation of webmin from 1.51 to 1.49.

If this doesn't correctly interpret the httpd.conf file, I think I'll give up on webmin for awhile and concentrate on getting all my virtual hosts up and running the old fashined way. Directly under apache.

And if this doesn't work, I plan on upgrading the O/S from SuSE 10.3 to 11.3 with a new Apache module and see if this doesn't work.

Getting virtual websites up and running shouldn't be this tedious, do you think?

Thanks to all who read this. Please. Feel free to lend whatever assistance you can.


blainemiller 07-27-2010 12:00 AM

erased 1.51 version of webmin and installed 1.49. No change... That is, the default and primary websites seem to work. My second website,, appears to still be pointing to either the default or primary site(s).

I'm giving up on Webmin for now and will try to configure Apache to run multiple virtual websites.

Any pointers, greatly appreciated.



blainemiller 07-27-2010 12:54 AM

Next note-->

when I do a { service apache2 configtest } I get:

service apache2 configtest
[Mon Jul 26 22:52:07 2010] [warn] VirtualHost overlaps with VirtualHost, the first has precedence, perhaps you need a NameVirtualHost directive
Syntax OK

I don't understand what this means?

Thanks and thanks for looking...


blainemiller 07-27-2010 11:16 AM

New Note -->

When I tail -f the error_log file, I can see both websites, gtmachining & patriciaspostcards, coming through. However, only the gtmachining pages get displayed.

What am I doing wrong?

Thanks for your time and consideration...


All times are GMT -5. The time now is 07:53 AM.