LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   startx in fluxbox gives an empty black screen! (https://www.linuxquestions.org/questions/linux-software-2/startx-in-fluxbox-gives-an-empty-black-screen-4175516485/)

CodyAcer 08-27-2014 02:26 AM

startx in fluxbox gives an empty black screen!
 
hi! folks... i install fluxbox because for its lightweight window manager. its good for low RAM systems i tried it... but in the boot screen. i type
Code:

emely@Emely~# startx
result was an empty black screen

and when i try this
emely@Emely~# sudo startx
it works... but all of it features doesn't work.

like. e.g vlc, power management, all files and folders has no icons weird!

vlc wont start even i will start it in terminal
i have a
Code:

Linux Lite 1.0.8 i386
Default WM: GNOME


EDDY1 08-27-2014 02:39 AM

The sudo command has to be run in users shell. Also startx should be run as user. You're logged in as root.

CodyAcer 08-27-2014 02:42 AM

yeah... that is why.. im not comfortable logging in with sudo startx..., cause when i try to startx it just gave me an empty screen...!

naitso 08-27-2014 03:08 AM

black screen maybe correct, have you tried to click the right mouse button to show fluxbox menu? what do you see?

CodyAcer 08-27-2014 03:10 AM

no nothing happens i tried it..! i dont know why.. if i type sudo startx woah... it works.. it shows me the desktop and its fluxbox theme.. but i reboot and type startx omg.. nothing happens!

EDDY1 08-27-2014 03:36 AM

What OS?
You have gnome, is your login manager gdm3?

CodyAcer 08-27-2014 03:51 AM

uuhmmm.. yeah but im using console boot now...

EDDY1 08-27-2014 04:01 AM

At log screen after clicking on name there should be an to choose session or you need to reconfigure gdm3 to start fluxbox as default DE.


All times are GMT -5. The time now is 06:51 AM.