-   Linux - Software (
-   -   startx (display?) (

Atroxic 05-05-2002 11:45 PM

startx (display?)
Fatal server error: No screens found
XIO: Fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.

Basically, I want KDE to run, but this is what I get.

Someone told me to Export $display = localhost:0.0 or something like that, and doing that, I came out with this error, which is very similar as far as I can tell to the last one I had. Look the same to me. Please do what you can to help, Atroxic.

j-ray 05-06-2002 05:50 AM

do you run a completely new installation or was it already working before you changed sth?
you may configure X editing /etc/X11/XF86Config. you can use joe for this at command line. maybe you find what´s wrong inside there. good luck! jens

Aussie 05-06-2002 06:29 AM

If you have a look at /var/log/XFree86.0.log you will see a more verbose error message, post it here and it will give us a better idea of what the problem is.

Atroxic 05-06-2002 03:19 PM

Here it is, it's rather long though:


Atroxic 05-06-2002 07:12 PM

If any other information is needed just let me know, otherwise anything you know could help me to get this going. Thanks.


jpweston 05-06-2002 07:30 PM


I second j-ray's question of whether this is a new install or if you had X working before this trouble.

The bottom of the log you posted makes it look like there is no video card defined in the XF86Config file:


(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Take a look in /etc/X11/XF86Config and look for the following:


Section "Device"
            ##### multiple lines of commented Option values
            Identifier      xxxxx
            Driver            xxxxx
            VendorName xxxxx
            BoardName  xxxxx
            BusID            "PCI:x:x:x"

All of the x's should have data pertinent to your video card.

The log you posted shows that ati/radeon drivers are being loaded, but no card is found.

Let us know what you find.


jpweston 05-06-2002 07:37 PM


Just looked at the log you posted again. There's a line in there ~36 lines after the PCI Bus scan which reads:


(--) PCI:*(1:0:0) ATI unknown chipset (0x5157) rev 0, Mem @ 0xd0000000/27, 0xdfef0000/16, I/O @ 0xa800/8, BIOS @ 0xdfec0000/17
What video card do you have installed?


Atroxic 05-06-2002 10:28 PM

Pertaining to your question, When I had X running originally, it auto-found drivers for my Radeon (64 mb), but after I reformatted and installed 7.2 RH, I haven't been able to get it running since.


Aussie 05-07-2002 07:09 AM

First it might be a good idea to upgrade to XFree86-4.2.0 for improved ATI support, then from the console with no X server running do "xf86config" and write a new config file, pay particular attention to the graphic device section and pick the device that most closely matches your card.

oxman 05-07-2002 12:06 PM

same problem
PII 350
192 RAM
RH 7.2 enigma
KDE 2.2

wanted into install kfontinstall stand alone version RPM.
Dependency check indicated T1lib, mnglib and Qt2 needed.
Downloaded the rpms. installed them? The kfontinstall hung. tried logging out and x began respawning over and over. ctrl+all+del and x respawned over and over.

went linux single.
did start x
fatal server error could not open default font 'fixed'

XIO fatal IO error 104 (connection reset by peer) on xserver ":0.0" after 0 requests (o known precessed) with 0 events remaining.

below is the XFree86.0.log from /var

Any help would be greatly appreciated

DMR 05-07-2002 08:59 PM


oxman 05-07-2002 09:34 PM

further developments
Thanks to all who have responded. I ran Xconfigurator in run level 3 and had a perfectly good test page. Upon rebooting I still had the respawning problem. There seems to be some font and shared object problems.

Glockage 05-07-2002 10:39 PM

delete me

All times are GMT -5. The time now is 01:17 PM.