LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-07-2004, 12:53 PM   #1
RedHatMasta
Member
 
Registered: Nov 2003
Location: Central Kentucky
Distribution: Mandrake 10.0 Official
Posts: 77

Rep: Reputation: 15
Starcraft in Wine froze [had to reset], now CDROM won't mount!


I get

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

I was able to mount until just recently. The drive works correctly, because it still spins up and loads a bootable cdrom. I don't think it is too many mounted devices because I can mount my floppy and have unmounted my XP partition and it still won't mount.

I uninstalled wine and deleted all the extra files under /usr/bin/wine and /usr/lib/wine, but now what?

Oh and some other things that could be helpful:

[ben@kitties ben]$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 8 Feb 6 00:39 /dev/cdrom -> /dev/hdc

It looks like I'm going to have to reformat....
Btw I reposted this message cause I later found that my first subject didn't hint at the real problem enough.
 
Old 02-07-2004, 01:23 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Where are you mounting the cdrom? Did you try to mount as root? If it works as root, give users permissions to the driver with chown 666 /dev/cdrom and chmod 666 /dev/cdrom.

Root should be able to mount/umount the cdrom. If not, check the process running and see if any of those could be using the cdrom. If you find it, kill the application with killall -9 <application_name>.

If still does not work, kill X server and try to mount/umount the driver under cli and see if it helps. Well, those are all my cards so far

Good luck!
 
Old 02-07-2004, 03:24 PM   #3
RedHatMasta
Member
 
Registered: Nov 2003
Location: Central Kentucky
Distribution: Mandrake 10.0 Official
Posts: 77

Original Poster
Rep: Reputation: 15
Thanks for responding!!!

I get the same thing as root.

killall -l gives me:
HUP INT QUIT ILL TRAP ABRT IOT BUS FPE KILL USR1 SEGV USR2 PIPE ALRM TERM
STKFLT CHLD CONT STOP TSTP TTIN TTOU URG XCPU XFSZ VTALRM PROF WINCH IO PWR SYS
UNUSED

Can I kill bus? that looks like the only thing related to a cdrom.

None of those look like x/x11. So what do I kill?
Can I just go into init 1 or init 3?
 
Old 02-07-2004, 03:43 PM   #4
RedHatMasta
Member
 
Registered: Nov 2003
Location: Central Kentucky
Distribution: Mandrake 10.0 Official
Posts: 77

Original Poster
Rep: Reputation: 15
Ok I killed X, but it restarted. I logged in and then went to init 3, then init 1, and into root. I tried to mount it, and this time I got:

I/O error: dev 0b:00 sector 762972
I/O error: dev 0b:00 sector (lots more of the above, i.e 762536)
I/O error: dev 0b:00 sector 1048 [and 1024]
UDF-fs: No partition found (1)
I/O Error: dev 0b:00, sector 64
isofs_read_super: bread failed, dev= 0b:00, iso_blknum=16, block=16
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

Then I went to init 5, but it didn't bring up the gui. Then I went root and it started the gui. So I booted into ben. NOW IT MOUNTS THE CDROM!!!! But why now and not before? When I log into root and then into ben, does that have something to do with it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
must.. have.. starcraft (which wine to use?) End11 Linux - Games 17 03-09-2007 09:40 AM
starcraft with wine zexter Linux - Software 15 03-08-2007 08:05 PM
Starcraft and wine bird603568 Slackware 2 08-16-2005 09:03 AM
Kppp Froze>froze system>Lost a lot of data digitalhead Linux - Software 1 04-24-2005 09:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration