-   Linux - Software (
-   -   standard configure and Mandrake 10.1 CE (

FireHawk321 11-21-2004 12:14 PM

standard configure and Mandrake 10.1 CE
I have been installing everything from RPM's because the configure files that come with source code do not work for me. Recently though, I have been trying to install KSquirrel but it only comes in source. I got past the first error message I always encountered (gcc) by installing the gcc and g++ packages. Then the configuration ran a lot longer and I received
"checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!". So I found out that I need to install the Xorg files. I tried installing them and got an unsatisfied dependencies error. It needed "libpng_devel". So I get the RPM for that and try to install it but get another unsatisfied dependencies error. It needs "libpng" which is already installed!!! So I tried installing "libpng-static-devel" hoping that it might work but of course it needs the "libpng-devel". IT'S ONE BIG S--TY LOOP. This is really starting to make me mad because this is the standard configuration file that almost all source code on and use and Mandrake 10.1 CE can't even come with the right packages!!!

Any help is greatly appreciated.

chavo 11-21-2004 04:27 PM

Try using urpmi or Control Center to install those devel packages. It will automatically sort out any extra dependencies for you.

If you're going to be compiling pregrams, you're going to need the devel packages, there's no way around that. I try to install the devel package for everything I install, just in case.

FireHawk321 11-21-2004 05:55 PM

Thanks for the reply but the RMPDrake does not have all the RPM's for configurations alone and RMP's on the internet keep giving me an endless supply of dependencies sometimes they say that they need them self to install (example: libpng requires libpng to install).

FireHawk321 11-24-2004 05:18 PM

No, it did not solve the problem. I still receive
"checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!". I have installed nearly every Qt package too. Also, urpmi did not take care of any dependencies, I had to get them myself. What now interests me is "Make sure that you have compiled Qt with thread support!" Does Qt install with thread support as a default or do you have to add it some other way (more packages)?
Any ideas?

All times are GMT -5. The time now is 03:00 AM.