Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-30-2016, 06:52 PM   #1
LQ Newbie
Registered: Mar 2016
Posts: 2

Rep: Reputation: Disabled
ssmtp to gmail has stopped working

Below config had been working for years, and seems something has changed on gmail side. My account does not use 2 factor auth and is set to accept third party applications via ssmtp website.

Get the infamous: ssmtp: Cannot open

Telnet to that port works fine, so again, pretty sure Google has changed something since was working and stopped.

Anyone else experiencing this or found a resolution?


Old 03-30-2016, 07:09 PM   #2
Senior Member
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian Stable and Unstable
Posts: 1,943

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
I've always seen Google smtp using port 465. That's what works on my system.
Old 03-30-2016, 07:36 PM   #3
LQ Guru
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 18,980
Blog Entries: 28

Rep: Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068Reputation: 6068
Port 587 works for sending in my .msmtprc file:

tls on
tls_starttls on
tls_trust_file /etc/ssl/certs/ca-certificates.crt
auth on
from [username]
user []
password [password]
port 587
I notice you don't seem to reference a cert. I have no idea whether that's an issue; it's just something I notice.
Old 03-31-2016, 12:41 AM   #4
LQ Newbie
Registered: Mar 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks for info guys! So if anyone else runs into this and has made sure their gmail account is set to allow third party apps and isn't using 2 factor auth ... the resolution I found for this is in the hostname option in the ssmtp.conf file. I did have it set to, well now Google is apparently wanting a FQDN in that field so I changed it to and it seems to work (I just used fqdn of server I'm originating emails from). Strange. If anyone has more insight into why of this please let me know.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending e-mail from nmh or mail using ssmtp not working: Sampi Linux - Server 1 06-24-2018 10:51 AM
ssmtp: Cannot open rtcary Linux - Software 4 03-29-2016 10:33 AM
$ startx stopped working, was working fine when I shut it down last night BogoMIPS_1962 Slackware 2 08-10-2013 01:04 PM
[SOLVED] Sendmail segfault (ssmtp) on Gentoo Linux through Gmail. crosstalk Linux - Software 2 07-16-2010 01:29 AM
Three Mobile Broadband was configured and working but it has now stopped working and Tinabarma Linux - Newbie 0 10-20-2008 07:36 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:06 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration