LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-01-2005, 07:20 PM   #1
pwilkie
LQ Newbie
 
Registered: Feb 2005
Location: UK
Distribution: Mandrake 10.1 Official
Posts: 11

Rep: Reputation: 0
SSL devel packages installed - still can't connect to MSN via Gaim


Hi,

Browsing through this forum I see this is a very common subject. Apologies for adding to the list of threads discussing this but having gone through all the other threads I'm still having problems.

First up, Im running Mandrake 10.1 official, and have just installed Gaim 1.1.4 (downloaded from Gaim site)

Upon attempting to login I get the good old "install SSL libraries blah blah" message - I have since installed the following files:

libopenssl0.9.7-devel-0.9.7d-1.1.101mdk
libopenssl0.9.7-static-devel-0.9.7d-1.1.101mdk

The following file was already installed:

openssl-0.9.7d-1.1.101mdk

After installing the two library files above I unistalled gaim (make uninstall) and ran the configure script again. Here is the tail end of the output produced:

gaim 1.1.4

Build Protocol Plugins........ : yes
Protocols to link statically.. :
Protocols to build dynamically : gg irc jabber msn napster novell oscar yahoo zephyr

UI Library.................... : GTK 2.x
[B]SSL Library/Libraries......... : None[/B

Build with Plugin support..... : yes
Build with Perl support....... : yes
Build with Tcl support........ : yes
Build with Tk support......... : yes
Build with Audio support...... : no
Build with NAS support........ : no
Build with GtkSpell support... : no

Use kerberos 4 with zephyr.... : no
Use external libzephyr........ : no

Use XScreenSaver Extension.... : yes
Use X Session Management...... : yes
Use startup notification.......: no

Print debugging messages...... : no

Gaim will be installed in /usr/local/bin.

configure complete, now type 'make'

As you can see it doesnt seem to be finding the files.

Now the questions:

1. Have I installed the correct ssl files?
2. Am I missing any other files?
3. How do I sort this out? I dont want to have to revert back to version 0.8x that comes with Mandrake 10.1 (but does work with MSN 'out of the box'

I notice that the configure ouput produces these additional warnings as well:

checking for gtkspell-2.0 >= 2.0.2... Package gtkspell-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtkspell-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkspell-2.0' found
checking for dlopen... no
checking for dlopen in -ldl... yes
checking for ao... no
*** Could not run ao test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means ao was incorrectly installed
*** or that you have moved ao since it was installed.

checking for GNUTLS includes... ""
checking gnutls/gnutls.h usability... no
checking gnutls/gnutls.h presence... no
checking for gnutls/gnutls.h... no
checking for GNUTLS libraries... no
checking for mozilla-nss... Package mozilla-nss was not found in the pkg-config search path.
Perhaps you should add the directory containing `mozilla-nss.pc'
to the PKG_CONFIG_PATH environment variable
No package 'mozilla-nss' found

Are these related at all or seperate issues that will lead to problems later? I assume the GNUTLS check is the SSL check (I ran configure with the "--enable-gnutls=yes" option.

Thanks for any help!!
 
Old 03-02-2005, 03:40 PM   #2
pwilkie
LQ Newbie
 
Registered: Feb 2005
Location: UK
Distribution: Mandrake 10.1 Official
Posts: 11

Original Poster
Rep: Reputation: 0
Hello again,

I've sorted it. I've been a bit thick and just realised that it is actually the GnuTLS package that needs to be installed and not the openssl packages!!

Anyway, installed the files below and recompiled. Installed fine and can log onto my MSN IM account now:

GnuTLS Packages:
gnutls-1.0.13-1mdk
libgnutls11-devel-1.0.13-1mdk

Dependencies:
libgcrypt11-devel-1.2.0-2mdk
libgpg-error0-devel-1.0-1mdk
liblzo1-devel-1.08-4mdk
libopencdk8-devel-0.5.4-2mdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed GAIM, Won't Connect to MSN koodoo Linux - Newbie 2 08-16-2005 11:19 AM
GAIM and MSN need ssl sbrewer Linux - Software 10 12-19-2004 10:55 PM
why i can not install gnutls?(gaim,ssl,msn) lovelinux Linux - Software 1 04-02-2004 09:27 AM
SSL and gaim(msn) ckamheng Slackware 2 12-02-2003 10:29 AM
gaim msn problem ssl support sal_paradise42 Mandriva 4 10-16-2003 02:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration