-   Linux - Software (
-   -   ssh works outbound, but i get "no route to host" err inbound (

kline 12-09-2012 08:39 PM

ssh works outbound, but i get "no route to host" err inbound

i finally got past my bootloader problems [UEFI] on my new Dell 3010, and *finally* got KDE going. the major problem is ssh[d]. besides my server i have two boxes, ethos and tao. the problem is that i can do

% ssh ethos

from tao. i get to ethos in my /home/kline directory just fine. but when i try going back to tao:

% ssh tao

i get the port 22 error that there is "No route to host". of course i have googled around and even found a few [SOLVED] URL's. but nothing i do seems to resolve this prob. Any ideas?

thanks for any clues!

PS: sorry if i am re-asking. i got things working Once. my notes don't help, :(

unSpawn 12-09-2012 08:48 PM

If you

ssh kline@ethos 'host tao'
and get a "NXDOMAIN" error back, would it be possible to set a static IP entry in /etc/hosts? Or do ethos and tao use dynamic addresses w/o possibility of mapping their MAC to a static IP address in whichever machine provides DHCP?

kline 12-09-2012 11:10 PM

host tao yields::
pts/5 20:49 <ethos> [4589] host tao has address

i've got a hardware firefall in a netgear box. this delivers the DHCP to all my tower cases and my laptops. moreover, i'm pretty sure the is showing in the pf web software.

thanks, tho.

i'm about out of ideas. only a few things left, max.

unSpawn 12-10-2012 05:03 AM


Originally Posted by kline (Post 4845985)
pts/5 20:49 <ethos> [4589] host tao has address

OK so the host name resolves properly. Is TCP/22 open on tao? You're not using a different port? And it's not firewalled? And it doesn't have PAM, /etc/ssh/sshd_config or /etc/hosts.{deny,allow} restrictions? If none of that post output of

ssh kline@ethos 'ssh -vvv kline@tao'
and also what syslogs say on tao, if anything.

kline 12-10-2012 01:47 PM

my entire domain is behind a hardware firewall. sshd is on everywhere: on tao, on ethos, and on my server. until last week when i reinstalled fedora-17, i was able to ssh either way from anywhere. reinstalling wiped tao clean, of course. i'm trying to figure out how to get ssh[d] working.

as for your code, the output is::

pts/6 11:39 <ethos> [4639] ssh kline@ethos 'ssh -vvv kline@tao' /tmp
kline@ethos's password:
OpenSSH_5.9p1, OpenSSL 1.0.0j-fips 10 May 2012
Pseudo-terminal will not be allocated because stdin is not a terminal.
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 50: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to tao [] port 22.
debug1: connect to address port 22: No route to host
ssh: connect to host tao port 22: No route to host

see anything here?

kline 12-10-2012 03:33 PM

problem SOLVED
WEll, it works. the thing i needed to check-mark was in system-config-firewall. yes, i had used this before when installing Gnome. but then i only checkmarked [x] SSH 22/tcp; this is listed under the "Trusted Services" section. it has the std bunch of unix stuff such as FTP, TFTP, etc.

Directly below the the "Trusted Services" selection is "Trusted Interfaces" where I found my fblunder. in there [right-hand side] is "eth+" which i thought is pretty obvious if you're trying to get out of one box on your network to another box. {Maybe the last time i had things working, i used the Wizard option. [?]} At any rate--actually, there are [2] at-any-rates: first, this time i have only been at it for a couple hours so my brain aint dead yet. second, i guess, is that it's obvious to investigate things that should-be obvious ... but *aren't*.

this time, because i did only One thing at a time, i'm pretty sure that check-marking the "eth+" box got things going.

unSpawn 12-10-2012 03:35 PM

Well done fixing yourself, please mark thread "solved".

All times are GMT -5. The time now is 11:43 PM.