LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ssh problem (https://www.linuxquestions.org/questions/linux-software-2/ssh-problem-760350/)

elainelaw 10-07-2009 12:04 PM

ssh problem
 
I have two servers ( serverA and serverB ) , and setup ssh without password , I use the command "scp file testusr@serverB:/tmp " can scp file to serverB without password , it used for long time without any problem , but I don't know why I suddenly can't use it , I tried to re-setup it and restart sshd , but still not work, the error is

testusr@serverB's password



can advise what is the possible reason of it ? what can i do ? thx in advance.

tredegar 10-07-2009 12:12 PM

Try using the -v or -vvv option to either scp or ssh. This (Very Very)Verbose mode should tell you what is (not) happening.

Edit: You might also look here: http://linuxcommando.blogspot.com/20...-checking.html

(link lifted from http://www.linuxquestions.org/questi...ements-760292/ )

and tell us how much you know about this remote server, is it yours? Do you administer it? Have you changed anything on it recently?

/Edit

uteck 10-07-2009 12:27 PM

Off hand I would suspect that the key file in your .ssh is missing, or the .ssh directory on the other machine got messed with. Either the authorized_keys file, or the .pub files got moved.

Myiagros 10-07-2009 01:33 PM

Check the permissions on the .ssh folder. Make sure they are owned by the user you are trying to SSH with.


All times are GMT -5. The time now is 03:26 PM.