LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   SSH port 22 unblocking on the modem ? (https://www.linuxquestions.org/questions/linux-software-2/ssh-port-22-unblocking-on-the-modem-740619/)

Bodi 07-16-2009 04:54 PM

SSH port 22 unblocking on the modem ?
 
i've tried to set up on my ubuntu ssh so i can ssh to it from work, i installed openssh and all that and when i try to ssh to my computer from a computer which is on the same network, on the same modem i am able to connect fine but when i try to ssh from work to home i am not able to establish ssh connection

at home i got ubuntu with latest openssh available at work i've got windows with putty client

as i was reading about this in many articles it says to unblock the 22 port in the modem so i can access it through that port from the outside

other possible cause that i think of is if im not able to find my ip address on the network i am finding one ip address which is probably the outside address not the internal one

any suggestion how can i unblock the modem port 22 and how can i determine what my ip address on the internet is

Hammett 07-16-2009 05:37 PM

It is possible that at your work, the port 22 is closed, so you cannot go through that port, and not be able to connect to your computer at home. In that case, you should configure your work modem as well to enable that port.

The IP you have to use is your public IP, not the one your modem/router is giving to you (that one is for internal networking). There are numerous websites in internet that will tell you which public IP you have. Also keep in mind that if you have dynamic IP, it will be changing from time to time.

Bodi 07-16-2009 07:30 PM

ok im pretty sure that the 22 port at work is not blocked because i am using putty all the time, im constantly connect to a server and im ssh-ing all the time we are a webhosting tech support i do ssh-ing a lot but im not really able to set it up at home

aortiza 08-11-2009 10:41 AM

Apparently the openssh server is not installed in ubuntu by default.
Try
Code:

sudo apt-get install openssh-server


All times are GMT -5. The time now is 04:51 PM.