Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 12-17-2008, 03:26 PM   #1
Registered: Mar 2007
Distribution: Hardy (Gnome on Ubuntu 8.04) on Compaq N600c laptop
Posts: 323

Rep: Reputation: 30
SSH login keeps failing, saying that "strict" mode is on. ...It isn't

On /etc/ssh/sshd_config I've tried strict mode ="no" and just commented out. Is this a client side thing?

Last edited by lumix; 12-17-2008 at 05:20 PM.
Old 12-17-2008, 05:17 PM   #2
Senior Member
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Settings in sshd_config affect the SSH server (which runs as a dæmon process, hence the “d” suffix in sshd). i.e. settings here affect people attempting to log in to the computer that the sshd_config file is on. You may also need to restart SSH for changes here to take effect, typically with something like:
/etc/init.d/sshd restart
Also, strict_mode="no" is the correct setting to turn it off, according to a Google search:

Client-side settings live in the ssh_config file instead.
Old 12-17-2008, 05:17 PM   #3
Senior Member
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Instead of turning off StrictModes, why not make your home directory permissions better (i.e. more restrictive)?

By the way, the directive is: StrictModes no

Read the manpages for sshd_config(5).

Last edited by anomie; 12-17-2008 at 05:19 PM.
Old 12-17-2008, 05:23 PM   #4
Registered: Mar 2007
Distribution: Hardy (Gnome on Ubuntu 8.04) on Compaq N600c laptop
Posts: 323

Original Poster
Rep: Reputation: 30
Whoops, thanks for the heads up...I meant strictmode="no".

I also did do a restart. After removing the known_hosts file (in the client .ssh dir), I was at last prompted for a password again. But Why? This is a client-side thing.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
what is "sticky bit mode" , "SUID" , "SGID" augustus123 Linux - General 10 08-03-2012 04:40 AM
"cant login, login incorrect"init : Id "x" respawning too fast:disabled for 5 minutes allenwoxx Linux - Newbie 1 11-21-2008 10:45 AM
How to disable remore ssh login access of "root" user. ashishshukla Linux - General 3 10-07-2008 08:55 AM
"Have to automate the SSH login procedure through shell scripting" sorav Programming 2 11-21-2007 04:53 AM
I am getting "MODE NOT SUPPORTED" message when i login to suse 9.3 RAHUKUMAR Linux - Hardware 11 01-05-2006 10:22 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:14 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration