LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-14-2009, 08:07 PM   #1
zparihar
Member
 
Registered: Sep 2004
Distribution: Fedora, Debian
Posts: 60

Rep: Reputation: 15
Squid TCP Miss


Hey guys,

Need a little bit of help here.

I've setup squid as a reverse proxy server, but i keep getting TCP Miss 's

here is a small tail of /var/log/squid/access.log

174.123.123.123 - - [14/Sep/2009:19:00:48 -0500] "POST http://test.squid-caching.com/kitn/interface.php HTTP/1.0" 200 375 "-" "-" TCP_MISS:FIRST_UP_PARENT
174.123.123.123 - - [14/Sep/2009:19:00:48 -0500] "POST http://test.squid-caching.com/kitn/interface.php HTTP/1.0" 200 375 "-" "-" TCP_MISS:FIRST_UP_PARENT
69.63.180.245 - - [14/Sep/2009:19:00:48 -0500] "POST http://test.squid-caching.com/slots/...sBoxScore.php? HTTP/1.1" 200 1163 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/530.18 (KHTML, like Gecko) Version/4.0.1 Safari/530.18" TCP_MISS:FIRST_UP_PARENT
174.123.123.123 - - [14/Sep/2009:19:00:48 -0500] "POST http://test.squid-caching.com/kitn/interface.php HTTP/1.0" 200 375 "-" "-" TCP_MISS:FIRST_UP_PARENT
174.123.123.123 - - [14/Sep/2009:19:00:48 -0500] "POST http://test.squid-caching.com/kitn/interface.php HTTP/1.0" 200 375 "-" "-" TCP_MISS:FIRST_UP_PARENT
174.123.123.123 - - [14/Sep/2009:19:00:49 -0500] "POST http://test.squid-caching.com/kitn/interface.php HTTP/1.0" 200 375 "-" "-" TCP_MISS:FIRST_UP_PARENT

Ignore the IP addresses and the domain name... I changed them...

Why do i keep getting "TCP_MISS:FIRST_UP_PARENT" ?

That basically means that its not being cached correct?

What can i do to fix this?

Here is my info:

I'm running Centos 5.3 32-bit

Installed the repository version of squid:

yum -y install squid



[root@production-database ~]# rpm -qa | grep -i squid
squid-2.6.STABLE21-3.el5



I want to set up a Squid Reverse proxy server.


The remote webserver's internal ip address is:

10.4.81.130


The local Squid internal IP address is:

10.12.66.130



My squid.conf is:

cache_mgr root

# Basic parameters
visible_hostname www.squid-caching.com

# This line indicates the server we will be proxying for
http_port 80 accel defaultsite=www.squid-caching.com vhost


cache_peer 10.4.81.130 parent 80 0 no-query originserver name=myAccel



###### Basic ACL for Production Webservers #######

acl prod_sites dstdomain .desgames.com
http_access allow prod_sites
cache_peer_access myAccel allow prod_sites


###################################################

acl apache rep_header Server ^Apache
broken_vary_encoding allow apache

# Where the cache files will be, memory and such
cache_dir ufs /var/spool/squid 10000 16 256

cache_mem 4096 MB
maximum_object_size 128 MB
maxiumm_object_size_in_memory 8 MB

# Log locations and format
#logformat common %>a %ui %un [%tl] "%rm %ru HTTP/%rv" %Hs %<st %Ss:%Sh
logformat combined %>a %ui %un [%tl] "%rm %ru HTTP/%rv" %Hs %<st "%{Referer}>h" "%{User-Agent}>h" %Ss:%Sh

access_log /var/log/squid/access.log combined

cache_log /var/log/squid/cache.log
cache_store_log /var/log/squid/store.log
logfile_rotate 10
## put this in crontab to rotate logs at midnight:
## 0 0 * * * /usr/sbin/squid -k rotate &> /dev/null

hosts_file /etc/hosts

## Basic ACLs
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl Safe_ports port 80
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access allow localhost
http_access allow all
http_access allow all
http_reply_access allow all

icp_access allow all

cache_effective_group squid

coredump_dir /var/spool/squid
forwarded_for on
emulate_httpd_log on
redirect_rewrites_host_header off
buffered_logs on



Any help would be greatly appreciated!

Thank,

Zubin.
 
Old 09-14-2009, 08:17 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
My guess is that your issue comes from those being POST requests, which are not cacheable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid needs to cache port 1433 tcp banker_09 Linux - Networking 4 06-14-2009 06:18 PM
Linux change TCP kernel Parameter for TCP DELAY ACK TICKS linux_mando Linux - Networking 5 08-22-2006 09:20 AM
Squid proxy TCP/6112 chinkai80 Linux - Networking 1 08-09-2006 11:53 PM
squidGuard redirection gives TCP miss Recirqie Linux - Networking 4 11-20-2004 05:48 PM
Woody 3.0 Open Ports 1470/tcp/uaiact 1518/tcp/vpvd What for?How can I remove them? alexxxis Debian 5 07-05-2004 06:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration