LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-23-2004, 09:38 AM   #1
Osiris123d
LQ Newbie
 
Registered: Oct 2003
Posts: 18

Rep: Reputation: 0
Squid Problems


I am running Suse 9.1. I have Squid set up to run as a proxy for dansguardian. I got it all up and running good. The only problem is that all my internal web servers names aren't resovled by the proxy. I have one internal server called http://MUSForum with an IP of 192.168.1.3. If I try and go to http://MUSForum I get an error message of

--------------------------------------------------------------------
The requested URL could not be retrieved

While trying to retrieve the URL: http://musforum/

The following error was encountered:

Unable to determine IP address from host name for musforum

The dnsserver returned:

Server Failure: The name server was unable to process this query.

This means that:

The cache was not able to resolve the hostname presented in the URL.
Check if the address is correct.

Your cache administrator is webmaster.
Generated Mon, 23 Aug 2004 13:30:50 GMT by TC-Filter.MUSCampus.local (squid/2.5.STABLE5)
-------------------------------------------------------------------------------------------

Yet if I type in the IP I can go to it. I've been told the way to resolve this is to install squid as a reverse proxy with the following option --disable-internal-dns. I first downloaded the squid source from www.squid-cache.org, but it seems that that source doesn't work with Suse. So when I installed squid with Yast it all worked good. How can I give the --disable-internal-dns option if I can only use the YAST package??? Is there a way to do this option if I install with the rpm command?
 
Old 08-25-2004, 05:28 AM   #2
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
Maybe you could define musforum in the /etc/hosts file on the proxy machine?
 
Old 08-25-2004, 10:44 AM   #3
Osiris123d
LQ Newbie
 
Registered: Oct 2003
Posts: 18

Original Poster
Rep: Reputation: 0
I did put the internal web server in the hosts file and that doesn't work. Using the --disable-internal-dns option would allow me to tell the proxy server how to resolve names (whether to look at hosts file first then dns servers etc..). I was able to work out my problem because Windows Active directory lets you set an option when you set the proxy settings for IE to not use proxy for internal servers. So that worked out. This would have been an issue if I wouldn't have had a windows domain. I guess I would have had to use RedHat instead. This is something Suse needs to address because I swear the squid source doesn't work with suse.
 
Old 08-25-2004, 11:40 AM   #4
tuxvader
LQ Newbie
 
Registered: Jun 2004
Location: Oklahoma
Posts: 9

Rep: Reputation: 0
you might have to set up DNS services on the proxy ..

Just a thought

i might be wrong
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with squid msound Linux - Networking 6 06-03-2005 03:06 PM
Squid problems ... Pirahna Linux - Networking 3 12-06-2004 12:32 PM
Inital problems with squid colabus Linux - Newbie 1 08-04-2004 11:42 AM
Proxy problems!!!! Squid urfrndvd Linux - Networking 1 08-23-2002 03:12 PM
Problems with squid / smoothwall happytechie Linux - Networking 2 07-13-2002 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration