LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-25-2003, 06:03 AM   #1
MgF
LQ Newbie
 
Registered: Nov 2002
Location: Central QLD Australia
Distribution: RH7.3
Posts: 13

Rep: Reputation: 0
Squid Problem


Hi,
Lately I have noticed that after rebooting my RH 7.3 Box my squid doesn't function correctly. I can't seem to access internet web pages untill I do a Restart of Squid. After that it seem to work properly. What could be the problem. My Squid.conf file hasn't changed.

Help me please

Michael
 
Old 08-25-2003, 07:47 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
What do your logs say? Is squid running after you reboot your system? To check, you can give the command

#service squid status

What is the output of

# chkconfig --list squid
 
Old 08-26-2003, 06:00 AM   #3
MgF
LQ Newbie
 
Registered: Nov 2002
Location: Central QLD Australia
Distribution: RH7.3
Posts: 13

Original Poster
Rep: Reputation: 0
Hi ppuru,

I checked the things u said and squid is running. It also starts in runlevel 5. I checked the logs and i noticed that when squid used a particular DNS nameserver it wouldn'
t work. But once i was connected to the internet and i restarted Squid it would change DNS Nameservers and start to work normally. I had Bind running earlier but i stopped it from starting at startup but squid still grabbed the DNS Nameserver which wouldn't work from resolved.conf. I changed the Nameservers to the two which worked and saved it. But i am sure that when i restarted the box for some reason the value in resolve.conf changed back to the faulty Nameserver. Now i may have been seeing things as it was a long day but i will confirm it. If it does change back to the faulty Nameserver what could be doing it? Note i am not connected to the internet untill I manually dial up some time later.

Cheers

Michael
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Problem ajkannan83 Linux - Software 2 10-21-2005 09:48 AM
Some problem with Squid...? apache Linux - Networking 1 07-06-2005 06:54 PM
squid problem hansi umayangan Linux - General 0 10-25-2004 08:35 AM
squid problem supon Linux - Networking 0 10-05-2004 10:24 AM
Squid problem. hiplainsdrifter Linux - Networking 2 04-24-2004 08:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration