LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-01-2003, 02:19 AM   #1
Deep13
LQ Newbie
 
Registered: Oct 2003
Location: India
Distribution: RedHat
Posts: 11

Rep: Reputation: 0
Squid - Connection refused on port 3128


hi,
i installed squid successfully (with defauly setttings to test it)

when i use /usr/local/squid/sbin/squid to run...it doesnt show any errors or anything..
so configuration is proper but now when i try to test the proxy from other machines then it doesnt work...shows page can't be displayed.

i also tried to test it from terminal by using following comand :

squidclient yahoo.com

it shows me foll. error

client: ERROR: Cannot connect to localhost:3128: Connection refused

and i dont think i am using my port 3128 anywhere else...so its free...

any idea about this problem ?

here are some more details :

OS - RedHat Linux 9
Installed squid on local machine (which is not server) for testing purpose.
my squid.conf file - http://techbeta.com/4boards/squid.conf

please let me know if any other details are needed.

Thanks
Deep

Last edited by Deep13; 11-03-2003 at 04:22 AM.
 
Old 11-01-2003, 05:32 PM   #2
J_Szucs
Senior Member
 
Registered: Nov 2001
Location: Budapest, Hungary
Distribution: SuSE 6.4-11.3, Dsl linux, FreeBSD 4.3-6.2, Mandrake 8.2, Redhat, UHU, Debian Etch
Posts: 1,126

Rep: Reputation: 58
Have you run "squid -z" to create the cache?
 
Old 11-01-2003, 10:16 PM   #3
Deep13
LQ Newbie
 
Registered: Oct 2003
Location: India
Distribution: RedHat
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by J_Szucs
Have you run "squid -z" to create the cache?
???

i didnt find anything in intallation note file...
using it for the first time so didnt know...
will try it tmrw in the office and post the reply..


thanks

Deep
 
Old 11-02-2003, 10:15 PM   #4
Deep13
LQ Newbie
 
Registered: Oct 2003
Location: India
Distribution: RedHat
Posts: 11

Original Poster
Rep: Reputation: 0
When i run squid service start or squid -z it shows me foll error :

Quote:
[root@Taj1 root]# squid -z
FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Squid Cache (Version 2.5.STABLE1): Terminated abnormally.
CPU Usage: 0.030 seconds = 0.010 user + 0.020 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 409
Aborted
my current visible hostname is Taj1
i still dont know why its showing the error.

Deep
 
Old 11-03-2003, 02:52 AM   #5
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
hello

i alos face this error, i just set full qualified host name then it satart work, i alos read some where before squid DNS server should also run, mean first confogure DNS server then squid.
any way i just set fully qualified hostname in system setting -->netwok -->Hosts
hosts name should be like this linux .com or redhat.linux.com

may u resolve your problem
i am also trying to configure squid

Regards
 
Old 11-03-2003, 02:55 AM   #6
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
hello

and please also type hostname in dns tab in same network tool
and dns server ip address , u can also use ISP dns server IP addrsss
regards
 
Old 11-03-2003, 03:41 AM   #7
Deep13
LQ Newbie
 
Registered: Oct 2003
Location: India
Distribution: RedHat
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mobassir
hello

and please also type hostname in dns tab in same network tool
and dns server ip address , u can also use ISP dns server IP addrsss
regards
hi,
i did all that..
i m using my ISP's DNS servers

same hostname is there in DNS tab as well as in Hosts tab..and in squid.conf

as far as i know the config of the file is proper but still cant find the problem.

i read the user guide and config manualy on squid-cache.org but there also nothing is specified for my perticular problem..

i hope it gets sorted out soon

Deep
 
Old 11-03-2003, 04:02 AM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
You've added

visible_hostname Taj1

to squid.conf ?

Last edited by Looking_Lost; 11-03-2003 at 04:04 AM.
 
Old 11-03-2003, 04:21 AM   #9
Deep13
LQ Newbie
 
Registered: Oct 2003
Location: India
Distribution: RedHat
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Looking_Lost
You've added

visible_hostname Taj1

to squid.conf ?
yes

i added it and also tried commenting that part but both of them didnt work.

Deep
 
Old 11-05-2003, 04:20 AM   #10
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
hello
i solve this problem.

FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Use help under network Configuration , system setting-->network--> Help-->conetnts--> managing DNS setting.

i solve my problem with this help , try may u also solve urs problem

Regards
 
Old 11-05-2003, 08:55 AM   #11
Deep13
LQ Newbie
 
Registered: Oct 2003
Location: India
Distribution: RedHat
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mobassir
hello
i solve this problem.

FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

Use help under network Configuration , system setting-->network--> Help-->conetnts--> managing DNS setting.

i solve my problem with this help , try may u also solve urs problem

Regards
yup i will check it and i also found one more way..

use webmin and let it do everything for u...and believe me it WORKS

regards
Deep
 
Old 11-06-2003, 12:40 AM   #12
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
hello

i am also trying with webmin , it always gives me version unsupported error, i explain the error in my webmin question thread.

Thanks
 
Old 12-02-2009, 03:49 AM   #13
huangyong
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Rep: Reputation: 0
Smile I also face the same problem i solve it now

I have checked through squid.conf through for a long time,and i failed.
then i reboot the proxy server. and the squid reboot.
I try squidclient -p 80 mgr:info
shell echo client: ERROR: Cannot connect to localhost:80: Connection refused

and then i tried squidclient -p 80 -h [my sever's ip]mgr:info
and a lot of information was printed.

maybe this will be help for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
port 25 connection refused even from localhost?? Ed1952 Red Hat 2 11-15-2005 08:24 AM
Connection refused error for port 25 jgnasser Linux - Networking 3 08-25-2004 07:09 AM
port 22: connection refused lkalman Linux - Networking 13 06-17-2003 07:55 PM
Connection Refused on port 9240 Rustiy Linux - Networking 2 04-22-2003 09:48 AM
Failed to start squid because port 3128 is in use Frankd Linux - Software 0 10-14-2002 02:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration