LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   sounf problems in quake3 and UT. (https://www.linuxquestions.org/questions/linux-software-2/sounf-problems-in-quake3-and-ut-34658/)

gonus 11-05-2002 01:49 PM

sounf problems in quake3 and UT.
 
My sound works with xmms and soldier of fortune but I cannot get sound in Unreal Tournament or quake 3 arena. I know nothing about thesound parts of linux, so any thing you need to help me figure this out pls let me knwo and I will post it ASAP.

Gonus

hazza96 02-15-2003 08:56 AM

Did you get this problem fixed? I am having the same issue, in my log I get the following lines:

Log: Bound to ALAudio.so
Log: Audio init failed

Regards
Harry

gonus 02-23-2003 12:46 PM

Yes I got it fixed. For me it was a reinstall of one game. The other game was not playing cause something else was using my sound card.

Blaa269 01-10-2004 06:03 PM

I am still having a Problem. I am using the most current copy of the Q3A its a Demo but I still get no sound. I read somewhere else that I should run some funny commands to check what is using my sound card and even after closing all things using my card it won't work.

megaspaz 01-11-2004 12:03 AM

one using mandrake, the other using suse so i'm going to assume you're running on KDE. the simple thing i've found was to use the artsdsp command. this should allow you to get sound on your games even if something else is using the card to, like xmms.

ie:

[prompt] $ artsdsp /usr/local/games/ut2003_demo/ut2003_demo

you can also use this as the execute command in a desktop shortcut. this command doesn't work for everything though but i don't have a list either. you'll just have to test this out one by one.

if you peeps are gnome users, then i don't know what you'd do.

Blaa269 01-11-2004 01:09 PM

I ran that command and it nicely also let me see what Quake was doing and I came across this line:
Code:

------- sound initialization -------
/dev/dsp: Broken pipe
Could not toggle.
------------------------------------

I looked in the /dev directory and I don't have this dsp file or folder is that a probelm?
Where do I get DSP?

Blaa269 01-11-2004 01:10 PM

I think it is somehow related to the fact that i didn't install the development pack with Mandrake. I have to go install that all.


All times are GMT -5. The time now is 10:21 AM.