LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Soundcard doesn't work until I run system-config-soundcard (https://www.linuxquestions.org/questions/linux-software-2/soundcard-doesnt-work-until-i-run-system-config-soundcard-406033/)

The_Nerd 01-21-2006 12:44 AM

Soundcard doesn't work until I run system-config-soundcard
 
I have this very strange problem after installing the new motherboard I just bought. My sound doesn't work at all until I run "system-config-soundcard". However, just running it isn't enough, I have to push the "Play test sound" button, it plays it's little sound, and then the whole system is happy afterwards. Why? I've looked at the modules loaded into the kernel, and they look fine. I've even manually tried inserting the right one, but no effect. I've also tried restarting ARTSD. My system is thus:

AMD Althon 3500+
Fedora Core 3, kernel 2.6.11-2

Soundcard detection utility gives the following info:
Vendor: nVidia
Model: Corporation nForce3 250Gb AC'97 Audio Controller
Module: snd-intel8x0

My motherboard is an ECS Elitegroup nForce3.

Anyone know what's wrong?

halvy 01-21-2006 04:47 PM

run alsaconfig, it will safe your settings.

royalfox 02-11-2006 10:53 AM

alsaconfig isn't on my system. I did a package scan with yum and concluded it is an out-dated utility (I'm using alsa drivers V1.0.10). Prior to scanning with yum, I found alsaunmute on my system and gave it a try and that's all it took to make my sound card work:) .

In order to make this permanent, I added:
/usr/bin/alsaunmute 0
to the final line in the start section of my /etc/init.d/alsasound init script (My card is card 0. I imagine in a 2-soundcard system, second card is card 1, adjust for your configuration). I now have sound following a reboot without running system-config-soundcard.


All times are GMT -5. The time now is 01:36 PM.