-   Linux - Software (
-   -   sound on one KDE login but not another (

kevinbenko 10-19-2008 10:39 PM

sound on one KDE login but not another

Reinstalled Debian Lenny on my wife's computer from a netinstall CD. [[power loss + journaling filesystem = screwed up file system]]

She is using KDE version 3.5.9

Now, in my login, I have system sounds and amarok, for example, works fine.

My wife's login, no system sounds, amarok gives the following error:
"xine was unable to initialize any audio drivers"

Note: my wife and I both have the same "groups" list.

I've compared control panel settings and amarok settings between accounts, with no notable differences, I've copied my amarokrc file over hers.

Since ogg123, mpg123, and mpg321 work for her, I believe that this is a KDE-specific configuration error, since all KDE-based audio applications fail to work on her login.

I suspect that if I copy all of my KDE configuration files into her directory that it might work, but she'd be upset if she had to reconfigure the look and feel of her KDE login.

kevinbenko 10-20-2008 01:04 AM

Problem Solved
I seem to have solved the problem.

To check if the problem was within the .kde directory, I renamed .kde and logged in as my wife. This, of course wiped out all of her settings, but she had system sounds and KDE-specific audio applications worked. Then, I deleted the new .kde directory and renamed the old one back to .kde with the intent of focusing my efforts on the .kde directory.

Well, system sounds still worked, as well as KDE-based audio applications. So, the problem was apparently not within the .kde directory.

Using the might "find" command and grep, I found that the following files were altered when I logged in without a .kde directory:


I have no idea why it works now, I would make an uneducated guess and think that when .kde was regenerated, some additional files were found to be hosed or missing and were then regenerated by KDE.

Anyone have any suggestions as to why this worked?

All times are GMT -5. The time now is 03:33 PM.