Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 06-18-2004, 09:31 PM   #1
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
Question Sound levels

First of all, I'd just like to celebrate that this is the first post I've been able to type from this laptop!

Second, I'm having a slight problem with sound. I'm not too familiar with how sound works under Linux, but I know I had to run alsaconfig to set everything up. Now, even though my alsamixer settings never change and are all at the correct levels, I don't get any sound from the machine. The only way I've found to get it to work is to go into kmix, move the two sliders on the left up (they're initially at zero), and then play the sound. This works for the session, but everything is back to zero again after I reboot, even if I choose the "Set as default configuration" option in kmix. Why is this happening, and how can I fix it?

Old 06-18-2004, 10:16 PM   #2
Senior Member
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 48
Try going into Control Centre->Sound & Multimedia->Mixer

and click save current volumes, and check load at startup.
Old 06-18-2004, 11:00 PM   #3
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
I forgot to mention... I use fluxbox, not KDE. That's probably why the "Save current volumes as default" isn't working, since kmixer isn't loading every time. That was just a tool I found that would temporarily fix the problem, but I'd like to get my master volume set to an acceptable level by default on startup using Slackware/Fluxbox.
Old 06-18-2004, 11:21 PM   #4
Senior Member
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
You mean changing the volumes within alsamixer don't fix this?

Try this.

Adjust your volume with alsamixer first, then kmix.
After you hear the sound playing the way you like, go to a console and do this as root:

alsactl store

That will store all the volume settings, to be grabbed at reboot.
I forget, but you may have to add the command
alsactl restore
to /etc/rc.d/rc.local
It may already be in one of the other scripts.

Old 06-18-2004, 11:28 PM   #5
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Haha, <smacks self in head>. I hate when these things turn out to be something simple. I was poking around alsamixer in preparation for trying what you suggested and I realized the Master and PCM channels were muted. All's well now.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't my FC3 rc0 and rc6 levels not call kill script when entering those levels? dvkwiatk Linux - General 2 11-11-2006 09:09 AM
Help with permissions levels bison42 Linux - Newbie 7 02-22-2005 11:26 PM
Access Levels Obie Linux - Security 1 08-28-2004 05:58 AM
Sound levels reset themselves marsonist Linux - Software 2 05-08-2004 09:32 PM
Remembering sound levels after reboot adz Linux - Software 8 09-24-2003 09:55 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:06 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration