LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-21-2017, 07:25 PM   #1
ReginaBob
LQ Newbie
 
Registered: May 2017
Location: Regina,Saskatchewan,Canada
Distribution: Ubuntu 16.04
Posts: 24

Rep: Reputation: Disabled
sound distortion playing wave and mp3 files,Ubuntu 16.04LTS


I have removed and reinstalled both pulse audio and sound,still poor sound.Sound is set to not exceed 100%;audio on web apps such as Netflix and youtube not effected.Also no problem with DVDs played from the HDD.This is an intigrated sound card on an HP 7100 Elite Microtower.i7,860,Realtec ALC8885.Would an new sound card solve the issue?

Last edited by ReginaBob; 09-21-2017 at 07:29 PM.
 
Old 09-21-2017, 09:16 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 12,773
Blog Entries: 17

Rep: Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312
Have you tested the audio files on another computer to rule out the possibility that they are corrupt in some fashion?

I'm confident that they aren't but it's worthwhile to check.
 
1 members found this post helpful.
Old 09-21-2017, 09:35 PM   #3
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,299
Blog Entries: 1

Rep: Reputation: 685Reputation: 685Reputation: 685Reputation: 685Reputation: 685Reputation: 685
Sometimes pulseaudio gets a bit flustered. Restarting it helps it recover. Or a reboot.

$ pulseaudio --kill
$ pulseaudio --start

Note that it's auto --start (via init or systemd) if "autospawn = no" is NOT in the /etc/pulse/client.conf. Sometimes you have to remove and re-add the default soundcard. I have a pulse over the network setup and it'll get jank when two different connections are flooding the sound daemon. A stop/start of pulse or a stop/start of all the things using pulse tends to clear the air. Originally pulse only supported 48kHz, so if you tailor your sound apps to default to that you can avoid a lot of quirks. Most of my current pulse issus are because my networked pulse runs on a 1.48GHz dual core over a mostly saturated 10/100 wired network. A machine that also plays long form youtube content.
 
1 members found this post helpful.
Old 09-21-2017, 11:37 PM   #4
ReginaBob
LQ Newbie
 
Registered: May 2017
Location: Regina,Saskatchewan,Canada
Distribution: Ubuntu 16.04
Posts: 24

Original Poster
Rep: Reputation: Disabled
You are correct,frankbell;the same files sound fine on my even older laptop.Both machines are HP,with intigrated sound cards.Sounds like Shadow7 is on the right track.The only other thing I have'nt tried yet is playing them on a different player program,which seems unlikely the be a solution.I assume the settings are default;I don't know enough about the hardware specs to want to change from default settings.It seems to be working better since I re-installed the pulse audio(also removed fluendo).Guess I will keep doing the same every time it decides to go fuzzy on me.Thanks for the input.
 
Old 09-22-2017, 10:14 PM   #5
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 12,773
Blog Entries: 17

Rep: Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312Reputation: 3312
I've never had to troubleshoot a problem like this one, but one of the members of my LUG posted this link about Pulse Audio. You might find something to help your troubleshooting efforts: https://gavv.github.io/blog/pulseaudio-under-the-hood/
 
1 members found this post helpful.
Old 09-23-2017, 10:01 AM   #6
ReginaBob
LQ Newbie
 
Registered: May 2017
Location: Regina,Saskatchewan,Canada
Distribution: Ubuntu 16.04
Posts: 24

Original Poster
Rep: Reputation: Disabled
Pulse audio

Wow ,frankbell.I had no idea there was so much going on in Pulse audio.Thanks.I also tried a different player-VLC instead of Audacious.Seems to be working now.
 
  


Reply

Tags
mp3 tag, sound card, wave


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using K3B. It will not accept mp3's to record. Says I must convert songs to wave files. dwalt Linux - Newbie 16 03-30-2017 05:08 PM
i want to play wave files and mp3 files hariji Linux - General 3 07-16-2007 06:29 AM
Record mp3 or wave files in textmode zielman@solcon.nl Linux - Software 0 07-10-2006 02:03 PM
playing mp3 audio files in ubuntu! randell6564 Ubuntu 36 05-29-2006 04:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration