LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-06-2013, 10:47 AM   #1
chiendarret
Member
 
Registered: Mar 2007
Posts: 255

Rep: Reputation: 16
Sound card issue


Hello:
With Debian amd64 wheezy I was unable to get the sound card working correctly (bumping voice or sound) for a Gygabyte GA-X79-UD3 motherboard, while with other motherboards there are no problems.


:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation C600/X79 series chipset High Definition Audio Controller (rev 05)
02:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
03:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)

:~$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf9120000 irq 72
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfb080000 irq 17
2 [NVidia_1 ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xf9080000 irq 17

As far as I can understand, Intel is chosen by the system, while I should change to NVIDIA.

I found some suggestions how to make NVIDIA card first choice but they did not work.

Thanks for help
chiendarret
 
Old 02-06-2013, 06:56 PM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Devuan
Posts: 3,415
Blog Entries: 33

Rep: Reputation: 222Reputation: 222Reputation: 222
Hi,

The controller "GK104 HDMI Audio Controller (rev a1)" is for

"sound through the graphics card cable" to the screen...speakers., hp socket, and other controls

If you use the green 1/8" stereo socket of you sound device, I suggest you blacklist the hdmi modules

so they don't get in the way of a stable system env.

I do it like this..

/etc/modprobe.d/blacklist-mga
Code:
# blacklisted modules for PCI coldplug
# see also /etc/modprobe.d/blacklist-compat

blacklist rivatv

# For some bridges both intel-agp and i82875p_edac are loaded. If i82875p_edac
# is loaded first it will grab the device. Then intel-agp doesn't work.
# Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
# https://bugzilla.novell.com/show_bug.cgi?id=213840
blacklist i82875p_edac

# do not use "Boot Protocol" drivers, we prefer usbhid
# and they cause problems when loaded together with usbhid (#37726, #40861)
blacklist usbkbd
blacklist usbmouse

# disable PC speaker by default
# pcspkr is the standard driver, while snd-pcsp is the ALSA driver
blacklist pcspkr
blacklist snd-pcsp
blacklist nouveau # default graphics card driver
blacklist snd_hda_codec_hdmi  #hda-nvidia-digital-stereo
blacklist snd_hda_codec_realtek #hda onboard 5.1 surround
blacklist snd_hda_intel
blacklist snd_hda_codec
blacklist snd_hda_codec_hdmi #hda-nvidia-digital-stereo

Oh, Keys,
the dash(-) and underscore(_) are both recognised by the modprobe (or kernel)

Cheers, Glenn
 
1 members found this post helpful.
Old 02-07-2013, 01:42 AM   #3
chiendarret
Member
 
Registered: Mar 2007
Posts: 255

Original Poster
Rep: Reputation: 16
Thanks for the suggestions. With my machine I can't do much now because it is computing statistical mechanics via GTX-680 cards (to spare on the electricity bill, instead of working without any desktop, I am doing everything on a single computer, the risk of gnome leading to a chrash notwithstanding). At any event, does this fir your suggestions?

:/etc/modprobe.d$ ls
alsa-base-blacklist.conf i915-kms.conf
alsa-base.conf linux-sound-base_noOSS.conf
dkms.conf nvidia-kernel-common.conf
fbdev-blacklist.conf radeon-kms.conf

:/etc/modprobe.d$ cat alsa-base-blacklist.conf
# Uncomment these entries in order to blacklist unwanted modem drivers
# blacklist snd-atiixp-modem
# blacklist snd-intel8x0m
# blacklist snd-via82xx-modem
# Comment this entry in order to load snd-pcsp driver
blacklist snd-pcsp


or does this allow an even simpler approach?
Thanks
chiendarret
 
Old 02-07-2013, 08:34 PM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Devuan
Posts: 3,415
Blog Entries: 33

Rep: Reputation: 222Reputation: 222Reputation: 222
OK, I understand the system is busy,

I think your system has a more modular approach, all's good.

add the hdmi module to the alsa-base-blacklist.conf.

when you get a chance to reboot, it should be fixed.
(sometimes I need to reboot 2 times)

Another way, would be to use modprobe -r (remove)snd_hda_codec_hdmi
(warning, may interupt/crash other processes)

your system may not use/implement modprobe. but if it does...
as root,
Code:
modprobe -r snd_hda_codec_hdmi
I'd edit the file and wait for a good time to reboot.

Regards Glenn
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sound Card Issue again ALInux Linux - Hardware 2 04-29-2011 09:00 PM
Sound Card Issue KhanInsanity Linux - Newbie 2 09-22-2005 09:37 AM
sound card issue ricardof Linux - General 6 02-17-2005 01:55 PM
Sound card issue mpeavy Linux - Hardware 3 01-08-2005 11:55 PM
Sound Card Issue Bone Gnawer Linux - Newbie 1 10-15-2003 09:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration