LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Sound card issue (https://www.linuxquestions.org/questions/linux-software-2/sound-card-issue-4175448894/)

chiendarret 02-06-2013 10:47 AM

Sound card issue
 
Hello:
With Debian amd64 wheezy I was unable to get the sound card working correctly (bumping voice or sound) for a Gygabyte GA-X79-UD3 motherboard, while with other motherboards there are no problems.


:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation C600/X79 series chipset High Definition Audio Controller (rev 05)
02:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
03:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)

:~$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf9120000 irq 72
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfb080000 irq 17
2 [NVidia_1 ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xf9080000 irq 17

As far as I can understand, Intel is chosen by the system, while I should change to NVIDIA.

I found some suggestions how to make NVIDIA card first choice but they did not work.

Thanks for help
chiendarret

GlennsPref 02-06-2013 06:56 PM

Hi,

The controller "GK104 HDMI Audio Controller (rev a1)" is for

"sound through the graphics card cable" to the screen...speakers., hp socket, and other controls

If you use the green 1/8" stereo socket of you sound device, I suggest you blacklist the hdmi modules

so they don't get in the way of a stable system env.

I do it like this..

/etc/modprobe.d/blacklist-mga
Code:

# blacklisted modules for PCI coldplug
# see also /etc/modprobe.d/blacklist-compat

blacklist rivatv

# For some bridges both intel-agp and i82875p_edac are loaded. If i82875p_edac
# is loaded first it will grab the device. Then intel-agp doesn't work.
# Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
# https://bugzilla.novell.com/show_bug.cgi?id=213840
blacklist i82875p_edac

# do not use "Boot Protocol" drivers, we prefer usbhid
# and they cause problems when loaded together with usbhid (#37726, #40861)
blacklist usbkbd
blacklist usbmouse

# disable PC speaker by default
# pcspkr is the standard driver, while snd-pcsp is the ALSA driver
blacklist pcspkr
blacklist snd-pcsp
blacklist nouveau # default graphics card driver
blacklist snd_hda_codec_hdmi  #hda-nvidia-digital-stereo
blacklist snd_hda_codec_realtek #hda onboard 5.1 surround
blacklist snd_hda_intel
blacklist snd_hda_codec

blacklist snd_hda_codec_hdmi #hda-nvidia-digital-stereo

Oh, Keys,
the dash(-) and underscore(_) are both recognised by the modprobe (or kernel)

Cheers, Glenn

chiendarret 02-07-2013 01:42 AM

Thanks for the suggestions. With my machine I can't do much now because it is computing statistical mechanics via GTX-680 cards (to spare on the electricity bill, instead of working without any desktop, I am doing everything on a single computer, the risk of gnome leading to a chrash notwithstanding). At any event, does this fir your suggestions?

:/etc/modprobe.d$ ls
alsa-base-blacklist.conf i915-kms.conf
alsa-base.conf linux-sound-base_noOSS.conf
dkms.conf nvidia-kernel-common.conf
fbdev-blacklist.conf radeon-kms.conf

:/etc/modprobe.d$ cat alsa-base-blacklist.conf
# Uncomment these entries in order to blacklist unwanted modem drivers
# blacklist snd-atiixp-modem
# blacklist snd-intel8x0m
# blacklist snd-via82xx-modem
# Comment this entry in order to load snd-pcsp driver
blacklist snd-pcsp


or does this allow an even simpler approach?
Thanks
chiendarret

GlennsPref 02-07-2013 08:34 PM

OK, I understand the system is busy,

I think your system has a more modular approach, all's good.

add the hdmi module to the alsa-base-blacklist.conf.

when you get a chance to reboot, it should be fixed.
(sometimes I need to reboot 2 times)

Another way, would be to use modprobe -r (remove)snd_hda_codec_hdmi
(warning, may interupt/crash other processes)

your system may not use/implement modprobe. but if it does...
as root,
Code:

modprobe -r snd_hda_codec_hdmi
I'd edit the file and wait for a good time to reboot.

Regards Glenn


All times are GMT -5. The time now is 12:57 PM.