-   Linux - Software (
-   -   Sony Vaio running Mepis has no Fn controls for volume (

monty_2487 02-06-2011 02:58 PM

Sony Vaio running Mepis has no Fn controls for volume
I recently installed Mepis (Lenny I believe) on my vaio n320 and was extremely excited that my Fn keys seemed to work right off the bat. I could adjust brightness just fine, but when I attempted to control the volume, nothing happened. I can adjust the volume from the mixer, but no Fn key.

Any ideas? Thanks for reading,


frankbell 02-08-2011 07:40 PM

It may be an OS/hardware interaction thing that Linux does not understand.

I have a Dell with factory-installed Ubuntu. (The keyboard is clearly designed with Windows in mind, but it is nice that there are no Windows stickers on it.)

The Fn brightness keys work just fine; they are direct hardware controls. I've never gotten the Fn volume keys to work, not since I first unpacked the machine. I think they talk to the OS, not directly to the speakers, and that Ubuntu likely doesn't know how to listen to them. I put the volume control icons down to legacy icons from Windows.

I would be happy along with you if someone comes along and shows me that I've overlooked something.

Reminiscence Mode: I had two Toshiba laptops years ago. Only thing I miss is that they both had what-do-you call 'em rheostats for physical control of the volume level without software interaction.

monty_2487 02-09-2011 11:10 AM

Sadly, I ran Kubuntu 8.04 on the same machine for about two years, during which I never got the brightness controls or the power manager to work properly. The Fn volume keys worked right off the bat, so now I'm in a reversed situation! I thought maybe there was a script workaround I could use, but so far I haven't found anything. If I do come across something, I will share it with you, but no promises it'll work on your Dell.


sebnet 02-09-2011 11:54 AM

Well in Xfce all you need to do is open the keyboard manager and add a new shortcut for those keys. I don't know which DM you're running but I assume both KDE and GNOME have something similar. Failing that, there's always xbindkeys.

The commands you want to be running on the keypresses are (assuming you're using ALSA):

Volume up:

amixer set Master 5%+
Volume down:

amixer set Master 5%-
This works for me on an Acer netbook and I see no reason why it shouldn't work for any other netbook/notebook.

Hope that helps! :)

frankbell 02-10-2011 08:46 PM

sebnet, I will try this in my Fluxbox keys file and let you know what happens.

sebnet 02-11-2011 04:08 AM


Originally Posted by frankbell (Post 4254643)
sebnet, I will try this in my Fluxbox keys file and let you know what happens.

Have you tried it? I'm guessing it didn't work. :(

aerobeing 06-19-2011 03:12 PM

As a workaround in MEPIS 11 on Vaio VGN-FS850P/W, I just set some Win key combinations to change volume because the Fn key would not register. Did not work for Brightness controls, but if someone is interested, it's in Start, Settings, System Settings, Shortcuts and Gestures, Global Keyboard Shortcuts, KMix.

All times are GMT -5. The time now is 06:31 AM.