-   Linux - Software (
-   -   Sometimes not getting entire file when printing to a file in SeaMonkey (

blackhole54 08-06-2009 03:08 PM

Sometimes not getting entire file when printing to a file in SeaMonkey

I have frequently printed a file from SeaMonkey with no problems. But sometimes it will print only what it considers the first page, which is not the entire page as displayed in the browser. If I set the print options to a larger sized page, I get more, but not all, as expected. Instead of telling it to print ALL pages, I have tried manually telling it to print pages 1 to 10 (for example). I still only get 1 page. I don't have a printer to test whether printing it would show the same problem. I also don't have experience trying to print from other applications to have an indication whether this is a SeaMonkey problem or in the printing software.

Does anybody have any idea how I might get it to "print" the entire web page when this happens? Thanks in advance.

I am using SeaMonkey 1.1.17 on Ubuntu 6.10.
An example of a page where I have this problem is:

(BTW, can anybody tell me how to tag this post with the *phrase* "print to file" instead of the individual words? I've tried enclosing in double quotes, putting asterisks between and using underscores between.)

John VV 08-06-2009 08:06 PM

i am not running seamonkey at the moment so...
but in firefox 3.5.1 i get a 15 page "print preview " from the link you gave ""

but as i recall sometimes seamonkey had some trouble with dynamical generated pages .

blackhole54 08-06-2009 11:44 PM

Thanks for your input. It doesn indeed seem to be a problem with SeaMonkey. Checking a couple versions of Firefox with that same page, does the same thing as SeaMonkey but Firefox 3.0 gives 19 pages which seems to be the whole webpage. (Curious you got 15 pages with Firefox 3.5 and I got 19 with Firefox 3.0, but not a big deal to me.)

Right now SeaMonkey and Firefox are "out of sync" (which delays security patches to SeaMonkey after Firefox has been patched), but they are supposed to be back in sync when Seamonkey 2.0 is released. Maybe this bug will go away then. Thanks again.

All times are GMT -5. The time now is 08:29 PM.