LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   (SOLVED)Tomboy Notes: How to set URL to default browser? (https://www.linuxquestions.org/questions/linux-software-2/solved-tomboy-notes-how-to-set-url-to-default-browser-4175520530/)

bobww99 09-29-2014 09:25 PM

(SOLVED)Tomboy Notes: How to set URL to default browser?
 
I have Mint 13,mate with Firefox (backup) and Google Chrome. The http blue address, when activated in Tomboy Notes, opens up in Firefox browser. How can I set Tomboy to open up URL in default Google Chrome browser?---(SOLVED) See last entry.

teckk 09-30-2014 04:35 PM

Maybe something like
~/.local/share/applications/mimeapps.list
Code:

[Default Applications]
x-scheme-handler/http=midori.desktop
application/pdf=xpdf.desktop
image/png=gpicview.desktop

Or I've seen this
Code:

text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop

I think that you can find those with
Code:

xdg-mime query default text/html
xdg-mime query default x-scheme-handler/http
xdg-mime query default x-scheme-handler/https
xdg-mime query default x-scheme-handler/ftp

I think that you can
Code:

xdg-mime default google-chrome.desktop text/html
xdg-mime default google-chrome.desktop x-scheme-handler/http
xdg-mime default google-chrome.desktop x-scheme-handler/https
xdg-mime default google-chrome.desktop x-scheme-handler/ftp


bobww99 09-30-2014 11:07 PM

In Mint 17 Cinn. by left clicking "~/.local/share/applications/mimeapps.list" and choosing open link, I get this:

[Default Applications]
text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop
x-content/image-dcf=gthumb-import.desktop
image/bmp=gthumb.desktop
image/jpeg=gthumb.desktop
image/gif=gthumb.desktop
image/png=gthumb.desktop
image/tiff=gthumb.desktop
image/x-bmp=gthumb.desktop
image/x-ico=gthumb.desktop
image/x-png=gthumb.desktop
image/x-pcx=gthumb.desktop
image/x-tga=gthumb.desktop
image/xpm=gthumb.desktop
image/svg+xml=gthumb.desktop

[Added Associations]
x-content/image-dcf=gthumb-import.desktop;
image/bmp=gthumb.desktop;
image/jpeg=gthumb.desktop;
image/gif=gthumb.desktop;
image/png=gthumb.desktop;
image/tiff=gthumb.desktop;
image/x-bmp=gthumb.desktop;
image/x-ico=gthumb.desktop;
image/x-png=gthumb.desktop;
image/x-pcx=gthumb.desktop;
image/x-tga=gthumb.desktop;
image/xpm=gthumb.desktop;
image/svg+xml=gthumb.desktop;

If Mint13 reads:---------------This is an assumption (not at Mint 13 machine and may be different)
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop
x-scheme-handler/ftp=firefox.desktop
x-scheme-handler/chrome=firefox.desktop

Just insert:
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop

Above in place of. Click save and close/done. To retry Tomboy in Mint 13, left click any URL and see if it opens in Google Chrome.

Since Mint 17 and Tomboy work to open URL's in Chrome, reason states that Mate 13 mate would work also with the above fix. Will try, and get back and hopefully mark (SOLVED).

bobww99 10-01-2014 12:15 PM

UPDATE:
Might want to ignore above posts. A waste of time. Mint 13 is riddled with bugs. Example:Can't used suspend,freezes and locks up. If your computer can handle it, stick with Mint 17. I'm stuck with Mint 13 on a old machine with bugs but way better than Lubuntu 14.04LTS and Peppermint 3. They come with more numerous irritating bugs.

From:
Google search: https://www.google.com/search?q=mime...m=122&ie=UTF-8

"Bug Description---one of many.
No applications found in file manager preferences
https://bugs.launchpad.net/bugs/1016956
Launchpad
Jun 23, 2012 - ... to .local/share/applications/mimeapps.list makes no difference Release 13 Maya with Mate DE. ... Linux Mint Edit. New. Undecided.
This bug affects 3 people

From: http://www.cesareriva.com/category/mint-mate/
Linux Mint Mate: MIME settings reset
I am running Linux Mint Mate 13 Maya, to reset the personal MIME settings type just delete this file:

rm ~/.local/share/applications/mimeapps.list " ---------------------Bad advice?

Here is the solution: If newbie, leave Firefox/Tomboy/Mint 13 mate this alone. Do not do anything and live with it. I read through the above Google search and found two more different associated bug reports numbers, some dating around 2004. Seems to be a conflict between Mint 13 mate with Caja and a bond with Firefox. Big Hair Ball.

Will mark as (SOLVED).


All times are GMT -5. The time now is 04:29 AM.