LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-13-2009, 05:49 PM   #1
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Rep: Reputation: 15
SMB/Samba not working with CIFS.


I have a SMB server using Samba running on a Slackware 11.0 x86 computer, every other computer on the network (six different computers) can mount the network resource with the trivial command:

Code:
smbmount //10.0.0.180/smb_shared /mnt/mount_point
However, when I attempt to do this on a computer running a recent Slackware 12.2.0 (which is more recent than the rest of the computers, most of which run 11.0), I get:

Code:
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
This also happened recently on a laptop on which I also installed Slackware 12.2.0.

I have tried to search on internet search engines for an answer -- I found many others with similar issues, however with no proper answer, I also tried to study the man-page, the configuration file, I tried different commands, to no avail, how can I mount this resource? Why doesn't it work?
 
Old 01-14-2009, 11:11 AM   #2
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
SMB is now depreciated, new Samba installations are supposed to be using CIFS. While I can't say for sure (I don't have a Slackware 11 machine to test on), my first thought would be that the Slackware 11 package for Samba is not configured for CIFS, or at least, it just isn't enabled. Not necessarily something that is Slackware-specific, but just something that was handled different in the older Samba releases.

My first step would be to try manually mounting the share as SMB rather than CIFS with a command like:

Code:
mount -t smbfs //10.0.0.180/smb_shared /mnt/mount_point
If that works, then you know there is a problem with the CIFS implementation on the server. At this point your choices would be to simply use SMB (which is slower and not as flexible), or get CIFS working. The best way to get CIFS working would be to upgrade Samba on the server, but for that you are going to have to build a new version and that might be more trouble than it is worth to you.
 
Old 01-14-2009, 02:20 PM   #3
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by MS3FGX View Post
SMB is now depreciated, new Samba installations are supposed to be using CIFS. While I can't say for sure (I don't have a Slackware 11 machine to test on), my first thought would be that the Slackware 11 package for Samba is not configured for CIFS, or at least, it just isn't enabled. Not necessarily something that is Slackware-specific, but just something that was handled different in the older Samba releases.

My first step would be to try manually mounting the share as SMB rather than CIFS with a command like:

Code:
mount -t smbfs //10.0.0.180/smb_shared /mnt/mount_point
If that works, then you know there is a problem with the CIFS implementation on the server. At this point your choices would be to simply use SMB (which is slower and not as flexible), or get CIFS working. The best way to get CIFS working would be to upgrade Samba on the server, but for that you are going to have to build a new version and that might be more trouble than it is worth to you.
Thanks for the idea but I had already tried that (including other commands, such as giving it various user names with associated passwords), to no avail -- same error as written in the start of the topic.
 
Old 01-14-2009, 02:29 PM   #4
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Rep: Reputation: 44
Can't speak for slackware as I haven't used slackware in a few years. But on my CentOS 5.1 servers I have the following samba software installed



samba-common-3.0.28-0.el5.8
samba-3.0.28-0.el5.8
samba-swat-3.0.28-0.el5.8
samba-client-3.0.28-0.el5.8


the samba-client package provides /sbin/mount.cifs

I have a samba mount to a windows machine using a credentials file. You can also do it via command line either way

mount.cifs //location/to/windows/share/ /mnt/foldername -o user=username,password=password

username and password would be an account on the domain or the windows machine

I also use it this way with the credentials file

mount -t cifs -o credentials=/path/to/credentialsfile //location/to/windows/share/ /mnt/foldername


Or the 3rd way would be to add it to /etc/fstab

//windows-server/mount /mnt/folder cifs credentials=/path/to/credentialsfile 0 0




credentials file would be:

username
password




again, not sure if this will work on slackware but its how I mount cifs mounts on a CentOS box.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
amarok + cifs/smb = no seek ? Molly Linux - Software 5 04-09-2008 01:32 AM
Which ports for FreeNAS and CIFS/SMB TSloth Linux - Networking 1 02-22-2007 07:42 PM
mounting SMB/CIFS shares from FreeBSD scott2004 *BSD 2 10-21-2006 01:09 PM
Samba in Debian, smb.conf: smb passwd file = ?????????? henrnorl Linux - Software 1 10-06-2006 10:43 AM
Samba working, but SMB browsing not? JohnGalt00 Red Hat 3 10-17-2003 11:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration