LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-31-2012, 12:55 PM   #1
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Rep: Reputation: 8
Unhappy SmartCam compilation error


Hello,

I am trying to install smartcam in centos 6.0. after ./configure when I run make it gives the following error.

Code:
[root@localhost smartcam-1.4.0]# make
make  all-recursive
make[1]: Entering directory `/home/Admin/Downloads/smartcam-1.4.0'
Making all in src
make[2]: Entering directory `/home/Admin/Downloads/smartcam-1.4.0/src'
make  all-am
make[3]: Entering directory `/home/Admin/Downloads/smartcam-1.4.0/src'
g++ -DHAVE_CONFIG_H -I. -I..  -DPACKAGE_DATADIR=\"/usr/local/share/smartcam\" -DDATADIR=\"/usr/local/share\"  -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/atk-1.0   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -DORBIT2=1 -pthread -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -g -O2 -MT smartcam-SmartEngine.o -MD -MP -MF .deps/smartcam-SmartEngine.Tpo -c -o smartcam-SmartEngine.o `test -f 'SmartEngine.cpp' || echo './'`SmartEngine.cpp
In file included from SmartEngine.cpp:36:
JpegHandler.h:26:21: error: jpeglib.h: No such file or directory
JpegHandler.h:27:20: error: jerror.h: No such file or directory
In file included from SmartEngine.cpp:36:
JpegHandler.h:42: error: field ‘cinfo’ has incomplete type
JpegHandler.h:43: error: field ‘jerr’ has incomplete type
JpegHandler.h:44: error: field ‘srcmgr’ has incomplete type
JpegHandler.h:47: error: ‘JMSG_LENGTH_MAX’ was not declared in this scope
JpegHandler.h:52: error: ‘j_common_ptr’ has not been declared
JpegHandler.h:53: error: ‘j_common_ptr’ has not been declared
JpegHandler.h:55: error: ‘j_decompress_ptr’ has not been declared
JpegHandler.h:56: error: ‘j_decompress_ptr’ has not been declared
JpegHandler.h:57: error: ‘j_decompress_ptr’ has not been declared
JpegHandler.h:58: error: ‘j_decompress_ptr’ has not been declared
make[3]: *** [smartcam-SmartEngine.o] Error 1
make[3]: Leaving directory `/home/Admin/Downloads/smartcam-1.4.0/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/Admin/Downloads/smartcam-1.4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Admin/Downloads/smartcam-1.4.0'
make: *** [all] Error 2
Kindly help me out with this. Its really Important for me to use my phone as a webcam.

Thanks
 
Old 03-31-2012, 01:05 PM   #2
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Install libjpeg.
 
Old 03-31-2012, 01:16 PM   #3
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Original Poster
Rep: Reputation: 8
Thanks a lot. I was able to install it successfully. But now I am not able to load the drivers

when I run make -C /lib/modules/`uname -r`/build M=`pwd` in driver_src dir it gives me
Code:
[root@localhost smartcam-1.4.0]# cd driver_src/
[root@localhost driver_src]# make -C /lib/modules/`uname -r`/build M=`pwd`
make: Entering directory `/usr/src/kernels/2.6.32-220.7.1.el6.i686'
  LD      /home/Admin/Downloads/smartcam-1.4.0/driver_src/built-in.o
  CC [M]  /home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.o
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c: In function ‘vidioc_s_fmt_cap’:
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:174: error: dereferencing pointer to incomplete type
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c: In function ‘smartcam_write’:
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:533: error: ‘TASK_INTERRUPTIBLE’ undeclared (first use in this function)
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:533: error: (Each undeclared identifier is reported only once
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:533: error: for each function it appears in.)
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c: At top level:
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:563: warning: initialization from incompatible pointer type
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:599: error: ‘VID_TYPE_CAPTURE’ undeclared here (not in a function)
/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.c:601: warning: initialization from incompatible pointer type
make[1]: *** [/home/Admin/Downloads/smartcam-1.4.0/driver_src/smartcam.o] Error 1
make: *** [_module_/home/Admin/Downloads/smartcam-1.4.0/driver_src] Error 2
make: Leaving directory `/usr/src/kernels/2.6.32-220.7.1.el6.i686'
Kindly guide me.
Thanks
 
Old 04-01-2012, 04:57 AM   #4
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Original Poster
Rep: Reputation: 8
I was able to install it successfully but when I try to connect it using my samsung wave 525. It say. javax.microedition.media.mediaexception. Format Not Supported. I googled a lot about it but wasn't able to find any answer. I would be very grateful if someone can guide me through this.

Thanks a lot

Regards
 
Old 04-01-2012, 05:00 AM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Make sure you have the latest version of java or try openjdk.
 
Old 04-01-2012, 05:04 AM   #6
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Original Poster
Rep: Reputation: 8
My Pc has its latest version. My phone uses BAda OS it was JRE but I m not sure of its version. And I am getting this error in my phone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] smartcam client on Nokia cell - nullpointerexception on Connect LouRobytes Linux - Software 1 06-03-2010 07:39 AM
unable to resolve compilation error;./List.c:5: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ amolgupta Programming 3 01-09-2009 11:09 AM
Inkscape compilation error: *** [extension/internal/pdfinput/pdf-parser.o] Error 1 w1k0 Slackware 12 10-25-2008 10:53 AM
compilation error : /tmp/cczC6Kc3.s:7368: Error: unknown pseudo-op: `.ltorg' nankie Red Hat 0 08-19-2008 11:15 AM
Swann smartcam webcam drivers westside Linux - Hardware 2 06-09-2003 02:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration