LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Slackware64-current and Firefox-48.0 (https://www.linuxquestions.org/questions/linux-software-2/slackware64-current-and-firefox-48-0-a-4175586158/)

3rensho 08-03-2016 06:10 AM

Slackware64-current and Firefox-48.0
 
Tried building the newly released Firefox-48.0 on a Slack64-current machine. Build crashes early on with the following -

--enable-cpp-rtti
--disable-gnomevfs
--disable-accessibility
--disable-crashreporter
--disable-debug
--disable-pedantic
--disable-installer
checking for a shell... /bin/sh
checking for host system type... x86_64-pc-linux-gnu
checking for target system type... x86_64-pc-linux-gnu
Traceback (most recent call last):
File "/tmp/firefox-48.0/configure.py", line 94, in <module>
sys.exit(main(sys.argv))
File "/tmp/firefox-48.0/configure.py", line 22, in main
sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
File "/tmp/firefox-48.0/python/mozbuild/mozbuild/configure/__init__.py", line 239, in run
raise InvalidOptionError('Unknown option: %s' % without_value)
mozbuild.configure.options.InvalidOptionError: Unknown option: --libdir
*** Fix above errors and then restart with\
"make -f client.mk build"
/tmp/firefox-48.0/client.mk:370: recipe for target 'configure' failed
make[3]: *** [configure] Error 1
make[3]: Leaving directory '/tmp/firefox-48.0'
/tmp/firefox-48.0/client.mk:387: recipe for target '/tmp/firefox-48.0/obj/Makefile' failed
make[2]: *** [/tmp/firefox-48.0/obj/Makefile] Error 2
make[2]: Leaving directory '/tmp/firefox-48.0'
/tmp/firefox-48.0/client.mk:225: recipe for target 'profiledbuild' failed
make[1]: *** [profiledbuild] Error 2
make[1]: Leaving directory '/tmp/firefox-48.0'
client.mk:168: recipe for target 'build' failed
make: *** [build] Error 2
root@missi:/data/patches/mozilla-firefox$


I tried removing the --libdir entry from the build script and that eliminated that specific error but the others remain. I'm not sure what is causing the errors with configure.py. Can anyone shed light on the problem for me? Thanks in advance.

zhilla 08-03-2016 02:35 PM

Same problem here, on 14.2 x64 stable.

Rinndalir 08-03-2016 03:51 PM

Is this a regression from when you built the previous firefox version?

3rensho 08-04-2016 12:04 AM

Yes it is. Version 47.0.1 built without a problem.

zhilla 08-06-2016 05:59 AM

Quote:

Originally Posted by 3rensho (Post 5585676)
Yes it is. Version 47.0.1 built without a problem.

Same here.

3rensho 08-10-2016 02:36 AM

OK, I had a look here (http://www.linuxfromscratch.org/blfs...t/firefox.html) and according to that website software versions on Slack64-current aren't up to the dependency requirements for Firefox-48.0 yet. Compared my installed versions with those listed on the linuxfromscratch web site. So closing case until Slack catches up and moves on from 47.0.1.


All times are GMT -5. The time now is 08:14 PM.