-   Linux - Software (
-   -   Slackware LDAP Server Wont Compile (

snoop20 06-20-2011 07:42 AM

Slackware LDAP Server Wont Compile
Hi all,

On the latest slackware (or any i've tried) I've tried removing the --disable-sldap etc from the slackbuild and rebuilding the package to get the server binary.

However it never builds, and browsing the tgz package shows it as empty.

What gives?

bathory 06-20-2011 04:24 PM

Hi and welcome to LQ,

Try to download the latest stable release (2.4.23), create a .tar.bz2 archive from the .tgz and adapt the SlackBuild to it.
FYI I had installed it a while ago without problems on current-x64.
You might also disable "make test" as it takes long time to complete.


snoop20 06-20-2011 04:31 PM

I can do, but I can't see why Slackware would take the server out of the source, it disables it via the .configure according to the slackbuild.

I've already disabled the make test part. I'll give it another go straight from source.

Cheers, Andrew

bathory 06-20-2011 04:54 PM


It does so, because the package is the client part of openldap. It is used when ldap authentication is necessary. I also do not know why there is no server part package.


All times are GMT -5. The time now is 12:03 AM.