LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Slackware 9.1 + iproute2 package (https://www.linuxquestions.org/questions/linux-software-2/slackware-9-1-iproute2-package-109987/)

blackthunder 10-29-2003 12:04 PM

Slackware 9.1 + iproute2 package
 
Hey guys
the problem im having is when I issue a make command for this package. Ive tried many different version of the package, and still no change. I read somewhere that the in.h file needs to have #include <linux/socket.h> added to it.. and ive done that to both the files, one comes with iproute2, and the other is under /usr/src/linux/include/linux/in.h ....

heres some box info.

Kernel 2.4.22 (kernel.org)
os = slackware 9.0 and 9.1, both same issue.


make gives this error (See below)... Im not sure and have no idea what to do.. Ive looked all over the internet and the only shread of help I can find is ... to add "#include <linux/socket.h> to /usr/src/linux/include/linux/in.h on line 22 ish... this didn't help and the same error occurs.

Thanks if anyone can help....

Jonathan Carron

ive tried grep -R gr_group ./* and adding those in with the include
also... still no progress!

Im stuck!


MAKE ERROR:

root@jaxx:~/iproute2# make
make[1]: Entering directory `/root/iproute2/lib'
gcc -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g -I../include-glibc -include ../include-glibc/glibc-bugs.h -I/usr/src/linux/include -I../include -DRESOLVE_HOSTNAMES -c -o utils.o utils.c
In file included from ../include-glibc/netinet/in.h:7,
from utils.c:23:
/usr/src/linux/include/linux/in.h:141: field `gr_group' has incomplete type
/usr/src/linux/include/linux/in.h:142: confused by earlier errors, bailing out
make[1]: *** [utils.o] Error 1
make[1]: Leaving directory `/root/iproute2/lib'
make: *** [all] Error 2


All times are GMT -5. The time now is 12:45 PM.