-   Linux - Software (
-   -   Slackware 12.2 won't boot to initrd (

ryerke 01-10-2009 08:00 PM

Slackware 12.2 won't boot to initrd
The computer boots fine to the HUGE kernel, but if I set up initrd with the generic, I get the 'no /sbin/init on rootdev' error. I have the same setup on another computer and it works fine.

I'm using a standard Slackware install on a P3 ASUS TUSL2.
I have an Adaptec 2940xx that I use for the cd-rw. I think that may be causing the problem. I have used this card before with Slackware 12.0 and 12.1 without issue, but I noticed that mkinitrd seems to be fussier on 12.2.

Is is possible that the kernel (or initrd.gz) is interpreting the SCSI as hda? If so, what can I do?

ryerke 01-11-2009 01:38 AM

Got it.
I added aic7xxx module to the mkinitrd along with reiserfs and away we go.
One side sure and run lilo after making changes to lilo.conf or mkinitrd (so says Pat V.) Had I done that I think it would have taken less time.

ryerke 01-11-2009 06:37 PM

Something else...After getting up and running, I checked out the changelog and noticed an update for mkinitrd. Some of the issues that were fixed had contributed to the trouble that I was having.
Also, although my system was running fine with only the reiserfs mod being loaded at startup (before the upgrade to 12.2,) I noticed that loading aic7xxx seems to help my cd-rw drive to be identified without linux trying to load wd7000 and other scsi and raid drivers and, I think, making the drive more useful.
I always thought that you only need to load modules at boot for the drives and controllers that you will need for your boot partition. I would strongly recommend that if you have a controller (scsi or sata or whatever) that you add the module to mkinitrd even if it is not needed for boot. Not only will your /dev be identified more accurately, but you may find that the device functions better. It does on mine.

bapigoo9 01-11-2009 06:43 PM


Originally Posted by ryerke (Post 3404999)
Not only will your /dev be identified more accurately, but you may find that the device functions better. It does on mine.

Any specifications on how much better your device (what device?) is running? Using the correct driver for a device is always what you should do. You have solved your post question?

ryerke 01-12-2009 12:52 AM

When I had the computer booting to the HUGE kernel, the Adaptec card would attempt to load the aic7xxx driver followed by numerous other drivers and eventually be identified by wd7000 (Western Digital scsi controller) according to lspci. I could play cd's and even write cdr's but I didn't have all of the options that I should have had with the HP CD-Writer. I also don't think that I was getting the performance that I should have been getting. Adding aic7xxx to the initrd has caused the scsi card to remain Adaptec 2940xx in lspci.
Yes, the problem is solved. I was not able to boot until I added the aic7xxx to the initrd. I think that the controller was confusing the boot process into thinking that the scsi was hda, making the ide channes 1 appear as hdb. I considered trying to change the boot device to hdb1 but that seemed like more of a hack than a cure for the problem. Adding the module to inird straightened everything out so that I can boot to hda1.

All times are GMT -5. The time now is 06:16 PM.