LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-16-2017, 12:20 PM   #16
wjones42
LQ Newbie
 
Registered: Mar 2017
Posts: 8

Original Poster
Rep: Reputation: Disabled

Cynwolf,
I meant after I reinstalled and tried sudo, etc. and couldn't get things going.
When both root and user account could run startx was after reinstall, before re-running slackpkg.
Things got ugly after running slackpkg both times.
This time (3rd time), I ran slackpkg from root immediately after reinstalling.
I was told there were .new files for LILO and did I want to overwrite the old. I said yes.
This time I ran:
slackpkg upgrade
slacpkg upgrade-new
slackpkg upgrade-all
(I forgot to run slackpkg pgp, is it too late now to do that?)
I've not even bothered with startx this time. I'm just sticking to lynx until I need KDE
My video card is a ZOTAC GeForce GTX 970 4GB. I use the default VESA drivers since they are fast enough for me. (Even when I was in KDE, the response was as fast as in Windows 10, so why bother? Besides, I'm having this much fun with slackpkg, I can't imagine the fun I'd have installing nVidia drivers. I don't want to find out either.)
 
Old 03-16-2017, 12:25 PM   #17
wjones42
LQ Newbie
 
Registered: Mar 2017
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cynwulf View Post
Generally, X related errors will appear in the system message buffer, or one can check the X.org log files in /var/log/

The OP hasn't posted any console output, nor given the OS release, kernel version, etc...

They also haven't specified the type of upgrade, whether just a general update or an attempts to upgrade from one release to another.

So not a lot to go on and guesswork isn't that useful.

Interestingly, the "tags" at the bottom of this thread include the phrase "slackware -current".
OS=Slackware 14.2 There was a new kernel downloaded and installed with slackpkg. I don't know how to find it's version. I installed 14.2 from a downloaded ISO file to a clean hard drive.

There were no X related errors. I typed startx at the console prompt and nothing happened. The BASH prompt didn't even reappear until after hitting CTRL+C a few times. (I walked away and watched a TV show for about 15-20 minutes before coming back to the console screen and seeing nothing happening.)
 
Old 03-16-2017, 01:08 PM   #18
RadicalDreamer
Senior Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 1,439

Rep: Reputation: 717Reputation: 717Reputation: 717Reputation: 717Reputation: 717Reputation: 717Reputation: 717
Slackware doesn't enable sudo by default.

Are you using huge kernel or generic? If generic did you rebuild initrd off the new kernel and specify initrd = /boot/initrd.gz in lilo.

What computer architecture and mirror are you using?

What does /var/log/Xorg.0.log say after you try to startx?
 
Old 03-16-2017, 01:41 PM   #19
jek404
LQ Newbie
 
Registered: Mar 2015
Location: USA
Distribution: Slackware
Posts: 29

Rep: Reputation: Disabled
Quote:
Originally Posted by wjones42 View Post
OS=Slackware 14.2 There was a new kernel downloaded and installed with slackpkg. I don't know how to find it's version. I installed 14.2 from a downloaded ISO file to a clean hard drive.

There were no X related errors. I typed startx at the console prompt and nothing happened. The BASH prompt didn't even reappear until after hitting CTRL+C a few times. (I walked away and watched a TV show for about 15-20 minutes before coming back to the console screen and seeing nothing happening.)
New kernel is 4.4.38
 
1 members found this post helpful.
Old 03-16-2017, 02:16 PM   #20
jek404
LQ Newbie
 
Registered: Mar 2015
Location: USA
Distribution: Slackware
Posts: 29

Rep: Reputation: Disabled
X Window System will not start after updating
 
Old 03-16-2017, 03:23 PM   #21
cynwulf
Senior Member
 
Registered: Apr 2005
Location: Walsall, UK
Posts: 2,642
Blog Entries: 7

Rep: Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165
How are you using the vesa driver? Explain in detail the exact steps you took to enable it.
 
Old 03-16-2017, 03:27 PM   #22
jek404
LQ Newbie
 
Registered: Mar 2015
Location: USA
Distribution: Slackware
Posts: 29

Rep: Reputation: Disabled
Quote:
Originally Posted by cynwulf View Post
How are you using the vesa driver? Explain in detail the exact steps you took to enable it.
Everything default: I did nothing specific to vesa
Default huge 14.2 UEFI on an Aapire 15
And then I followed the slackpkg instructions to a tee
I then tried again in run level 3 only
Startx will not run
 
Old 03-17-2017, 03:19 AM   #23
cynwulf
Senior Member
 
Registered: Apr 2005
Location: Walsall, UK
Posts: 2,642
Blog Entries: 7

Rep: Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165Reputation: 2165
In the case of "everything default", you should not be using the vesa driver? Have you looked at X.org log files to see what driver is actually being loaded?

nouveau is the driver usually loaded for nvidia GPUs, however...
Quote:
Originally Posted by wjones42 View Post
ZOTAC GeForce GTX 970 4GB
NV110 seems to be a work in progress:

https://nouveau.freedesktop.org/wiki/FeatureMatrix/

You may be stuck with the blob for now. Upgrading fully, as you have been and installing the nvidia proprietary Linux driver should resolve this.

Last edited by cynwulf; 03-17-2017 at 03:27 AM.
 
  


Reply

Tags
fubar, slackpkg, slackware -current, startx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to understand how slackpkg update works Zwergele Slackware 2 10-15-2014 03:08 PM
Since new kernel, Ethernet *finally* works, but Slackpkg and Gaim can't connect.... GrapefruiTgirl Slackware 52 11-17-2007 08:56 PM
Grub FUBARed mlitty Linux - Software 15 08-21-2007 03:39 AM
slackpkg doesn't works (problems with awk) sparc86 Slackware 8 04-11-2007 11:08 AM
Internet is fubared? Ne0BDP Linux - General 4 05-18-2004 06:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration