-   Linux - Software (
-   -   Slack 10, kernel 2.6.7, SB Live Value+ALSA, causing rosegarden headaches (

SocialEngineer 01-06-2005 12:17 AM

Slack 10, kernel 2.6.7, SB Live Value+ALSA, causing rosegarden headaches
Ok, so I compiled and installed rosegarden. I try to start it, and it says /dev/snd/seq doesn't exist - I check, and it doesn't. Anywhere.

I've got an SB Live! Value (5.1). Sound has worked fine, and I have had no problems. I have 0 clue as to why I don't have /dev/snd/seq.

Any clues? I didn't know which forum to post this to, so i just choice the software forum.

__J 01-06-2005 05:44 AM

are you using udev?

SocialEngineer 01-06-2005 12:27 PM


__J 01-06-2005 02:56 PM

Well, with udev it will not create an entry on /dev/ unless the drivers are loaded. make sure you have all the alsa drivers loaded (not just the base drivers).

SocialEngineer 01-06-2005 03:00 PM

How do I do that?

__J 01-06-2005 03:43 PM

do the following command (might need to be root):


when you execute lsmod see if you have a module name "snd-seq-device" (or on a 2.6 kernel snd_seq_device" if not try adding it in:

modprobe snd-seq-device (or on 2.6 kernels snd_seq_device) and see if that helps

this will show you what drivers are loaded into the kernel

you'll have to do a google for alsa and your card to see what it needs (sorry I've never had a SB)

SocialEngineer 01-06-2005 04:12 PM

Well, I decided to update ALSA. I did ./configure --with-cards=emu10k1 --with-sequencer=yes, and it doesn't create /dev/sequencer. No idea why.

__J 01-06-2005 04:17 PM


you mean /dev/snd/seq?

is the snd_seq_device driver loaded into your kernel?

SocialEngineer 01-06-2005 04:31 PM

Either one. Yeah, lsmod says it's there. the Alsa install guide says to chmod /dev/sequencer, as well as others, but /dev/sequencer doesn't exist... So.. Heh. /dev/snd/seq still doesn't exist either.

Note, this is after the ./configure, make, and make install of Alsa-driver 1.0.7.

__J 01-06-2005 04:34 PM

you might have to make an entry to /etc/modules.conf.

might want to try the hardware section of these forums surely someone around here has a SB and alsa on a 2.6 kernel.

SocialEngineer 01-06-2005 05:48 PM

Yeah, I posted a thread over here.

Thanks for your help.

Linux.tar.gz 04-14-2005 01:32 PM

You need this:
modprobe snd-seq-midi

All times are GMT -5. The time now is 07:58 PM.