LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-27-2011, 12:00 AM   #1
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-17.3 with Cinnamon & KDE
Posts: 1,679
Blog Entries: 3

Rep: Reputation: 105Reputation: 105
skype for linux won't use logitech C905 (V-UBU48) built-in mic


I fetched Skype onto my Ubuntu Lucid laptop and connected my Logitech C905 webcam. Video works, but I cannot get the mic operational.
If I connect a Logitech 2-wire headset (one mic + one headset)
all works well.

Skype tells me that it sees PulseAudio (server) for the audio.
My googling reveals loads of material about ALSA and "mixers"
and plenty of sound subsystem things that were well out of my
experience.

I have the same problem with this hardware and Skype on v10.10.

Can anyone shed any light on getting this to work?

Thanks in advance,
~~~ 0;-Dan
 
Old 09-27-2011, 03:29 AM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,710

Rep: Reputation: 107Reputation: 107
Hya,

I also had similar frustration. I tried skype on three Penguins, two of them work, one never. One of them works without pulse. Unless you need pulse, you can try to uninstall pulse.

good luck

Last edited by kaz2100; 11-02-2011 at 05:38 PM. Reason: typo
 
Old 09-27-2011, 04:44 AM   #3
splintercdo
Member
 
Registered: Feb 2011
Posts: 141

Rep: Reputation: 10
You could try to play with alsa+mixer

1. Open terminal and write: alsamixer

2. when application is executed(it runs in terminal itself, but is very easy to navigate) press F4 to go into capture section [sorry I cannot post screenshot right now]

3. Then try to change Input source(stereo mix, front mic, rear mic and so on)

and keep in touch tell what are the results

Edit... Try also other settings in playback section I see that it's possible to change mics in playback section too on ubuntu

Last edited by splintercdo; 09-27-2011 at 04:53 AM.
 
Old 09-27-2011, 02:28 PM   #4
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-17.3 with Cinnamon & KDE
Posts: 1,679

Original Poster
Blog Entries: 3

Rep: Reputation: 105Reputation: 105
Quote:
Originally Posted by kaz2100 View Post
Hya,
...
Unless you need pulse, you can try to uninstall pulse.
...
Thanks for the recommendation and reply.

Since I'm not a sound or audio maven, how do I benefit having pulseaudio installed? What does it bring to my audio listening experience?
I could simply remove it and see what happens, but I prefer to understand
first and act later rather than risk the need to tinker ( and tinker, ...
ad nauseum ... and tinker) to get it back and fix whatever went foul with the removal etc.

Cheers,
~~~ 0;-Dan
 
Old 09-27-2011, 05:53 PM   #5
splintercdo
Member
 
Registered: Feb 2011
Posts: 141

Rep: Reputation: 10
What you benefit is:
better sound integration in your system:
* you don't have to think much about configuring all of your applications separately (in theory) they just should run and wouldn't have to block each other, interact better between themselves.
* all sinks between applications and input output sources should be easily configurable through pulseaudio sound mixer, in fact most of the settings should do their job automatically, for example you connect your headphones to computer and pulse detects it and switches output to headphones(you can change it in pulseaudio control)
* this point is questionable, but by default settings you get a bit better latency settings with pulse than with alsa(you can change it by configuring /etc/asound.conf)
* without pulseaudio you won't hear any system sounds

conclusion: for starting linux users pulseaudio should be easier to use, that is why you could consider it better choice, BUT, if you use just ALSA, you basically can achieve all the same things and go beyond, that is the reason why advanced linux musicians mostly doesn't use pulseaudio at all(even thou there are some things where pulse helps a lot so it's not all that bad)
musicians usually have ALSA + JACK setup. (I prefer to use all three of them, just you have to remember that pulseaudio eats quite a lot of system resources, so if you have slower computer alsa + jack is better choice.)

So the bad things are:
* pulseaudio eats additional system resources
* pulseaudio have much worse latency than jack
* disputable, but I find, that, if I don't use pulseaudio "smart" jack detection, with just alsa my headphones and computer speakers always work, if I connect or don't do it with my heaphones.(So from this point alsa is easier to use, *you don't have to go to pulseaudio sound mixer and set back settings to analog output)
* pulseaudio is another sound layer on your computer, so you always have to remember your configuration of both alsa and pulse, to get things done(!!! so it's very disputable if really pulse is easier to use)

I might miss something, because am hurrying to go to sleep, but yeah, basically(if you don't mind loosing system sounds+you don't have some advanced needs for pulse, you can surely remove it and learn to use alsamixer[I hope so you followed my advices previously])

But you don't have to really remove pulseaudio just take it out of startup apps, for insurance go to /etc/pulse/daemon.conf find a line with autospawn and set it to no! And voila you have pulseaudio installed, but switched off, so if you don't like alsa setting, you can easily return to pulse
 
Old 11-02-2011, 01:49 PM   #6
Gonzalo_VC
Member
 
Registered: Nov 2009
Location: South America
Distribution: PCLinuxOS, X/Ubuntu LTS, MiniNo, antiX
Posts: 50

Rep: Reputation: 1
I have been experiencing the same problem: no mic in Skype under Ubuntu (I am running 10.04 LTS updated). Neither the internal net-book mic, nor the external mic on a PC).
Skype sucks!
And i hope Ubuntu people can work around this!
I won't give up on GNU/Linux, but may be Skype.
Anybody have tried Ekiga or another alternative?
Cheers!

Last edited by Gonzalo_VC; 11-03-2011 at 09:13 AM. Reason: (remove double entry)
 
Old 11-02-2011, 09:39 PM   #7
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-17.3 with Cinnamon & KDE
Posts: 1,679

Original Poster
Blog Entries: 3

Rep: Reputation: 105Reputation: 105
Quote:
Originally Posted by Gonzalo_VC View Post
I have been experiencing the same problem: no mic in Skype under Ubuntu (I am running 10.04 LTS updted). Neither the internal net-book mic, nor the external mic on a PC).
Skype sucks!
And i hope Ubuntu people can work around this!
I won't give up on GNU/Linux, but may be Skype.
Anybody have tried Ekiga or another alternative?
Cheers!

---------- Post added 02-11-11 at 15:49 ----------

I have been experiencing the same problem: no mic in Skype under Ubuntu (I am running 10.04 LTS updated). Neither the internal net-book mic, nor the external mic on a PC).
Skype sucks!
And i hope Ubuntu people can work around this!
I won't give up on GNU/Linux, but may be Skype.
Anybody have tried Ekiga or another alternative?
Cheers!
I, too, run Ubunto 10.04 LTS and finally got Skype working with the 905. As I remember
... I've slept since then ... I had to tinker the sound settings in preferences or administration from the System panel. The tinkering told linux about my sound resources
(given several, you must say which you want to use by default). Then when I started Skype, it saw the parts that I enabled. Skype can only pick from what is enabled.

I hope this helps,
~~~ 0;-Dan
 
Old 11-02-2011, 09:45 PM   #8
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,191

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
I have about 10 clients on different hardware, running Debian Squeeze. Skype sometimes works while Pulse is installed, sometimes not, and sometimes intermittently. Especially the last case is fully unacceptable. One day Skype works over Pulse, a few hours later you get called and either you don't hear a thing and can't talk back. If you have Pulse installed, you miss most of your volume controls, which is of course very logical to Pulse developers, but not to ordinary users.

Summarizing, uninstall Pulse and use Alsa until Pulse has matured.

jlinkels
 
Old 05-27-2012, 09:31 PM   #9
joekluse
LQ Newbie
 
Registered: May 2012
Posts: 1

Rep: Reputation: Disabled
Solution to audio problem with C905 on Ubuntu

This may be OBE, but I stumbled upon this thread. I was able to get skype on Ubuntu 10.04 to recognize my Logitech C905 mic, by doing the following:

1. If you have a speaker icon in the top or bottom panel, left click on it and go to step 2.
_____a. If not, then right click in the panel and select 'add to panel...'
_____b. Scroll down to 'indicator applet' and select it.
_____c. A speaker icon should now appear
2. Select 'Sound Preferences...'
3. Select the 'hardware tab' and select the webcam icon (mine says 080a, 1 input, Analog Mono input).
4. Select the input tab. In the 'choose a device for sound input, select '080a analog mono (or whatever yours was called in the hardware tab).
5. Set the input volume to a mid-way point and make sure the mute button isn't checked.
6. At this point if you talk, you should see the input level changing, indicating that it is recognizing sound coming from the camera mic. (note, it's difficult to see the display changing on my screen, you have to look closely).
7. Adjust the input volume until the input level goes to about 1/3 to 1/2 way when speaking normally.
8. Close the applet
9. Start Skype and make a test call. This worked for me, I'm hoping it works for you as well.

Please post and let me know if this worked for you.

Joe

Last edited by joekluse; 05-27-2012 at 09:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
getting mic to work in skype Faithfully10 Linux - Newbie 3 05-25-2011 05:26 PM
Kubuntu 8.10 skype no mic suppapowa Linux - Newbie 4 12-28-2009 12:41 PM
MIC is not working with skype in Fedora 10 myasir_genious Linux - Software 3 11-15-2009 12:13 PM
Skype - Logitech USB headset. No sound, no mic peteyperson Linux - Software 4 06-26-2009 05:57 AM
I can not get my in-built mic to work mandalasarah Linux - Newbie 5 01-30-2008 07:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration