LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Silent boot on Debian using LILO. (https://www.linuxquestions.org/questions/linux-software-2/silent-boot-on-debian-using-lilo-678946/)

Raffles666 10-25-2008 03:39 AM

Silent boot on Debian using LILO.
 
Hello :D.

I have done a quick search but can't see anything that describes the solution I'm after.

I am using Debian (etch) with LILO (GRUB won't work on my embedded solution) and everything works as it should.

The thing I am after is a 'silent boot'. That is - instead of all the start-up information being displayed on screen, all I want is something like 'Loading. Please wait...' or even nothing at all (goes direct to the 'login:' prompt).

Thanks in advance.

PS - sorry if this is in the wrong place - I'm a LQ newbie ;).

jonaskoelker 10-25-2008 06:39 AM

It sounds like you want to change what happens after your boot loader has passed control to the kernel. If that's the case, here's one idea: set up a boot splash with basically a black image saying what you want it to say. I'm quite sure that's done outside of the boot loader [not all boot loaders understand files and file systems; ISTR the boot splash being independent of your boot loader].

Search the web for a good guide setting up boot splashes, or try http://www.bootsplash.org/Debian :)

Raffles666 10-26-2008 04:31 AM

Thanks for that. That is 'sort of' what I am after. My embedded solution has no graphical monitor though - it's all done through a serial console (hence the reason I used LILO).

What I am trying to end up with is a basic prompt (eg. 'login:') without any start up information (graphical or otherwise). The reasoning behind it is so that end users can't see the 'engine' (even if they do a power reset) - just the login request (a bit like a Cisco router - but even they give out too much information on a reboot).

Is it possible to 'turn off' the ttyS0 output at the start of boot - and then turn it back on somehow just before the login prompt appears?

Hope that makes sense.

Thanks again :).

pinniped 10-26-2008 05:13 AM

Well, all that information is meant to help you troubleshoot, but if you want to get rid of it:

1. look at disabling 'PRINTK' support in the kernel
2. edit your startup scripts to dump messages to /dev/null or else a log file in RAM rather than dumping to the default console

Raffles666 10-26-2008 06:41 AM

Quote:

Originally Posted by pinniped (Post 3322156)
Well, all that information is meant to help you troubleshoot, but if you want to get rid of it:

1. look at disabling 'PRINTK' support in the kernel
2. edit your startup scripts to dump messages to /dev/null or else a log file in RAM rather than dumping to the default console

Agreed, the information is there to help ME - hence the reason I don't want my end users to see it (I wonder if I can check it with dmesg?).

I'll have a look around at PRINTK (new to me) and also see if I can work out how to dump the start up scripts to /dev/null (something I'd thought of - but have no idea how to implement). Wouldn't that involve editing every different /etc/init.d script though?

Thanks

EDIT : I've managed to restrict the output using 'quiet' as a kernel command line option (in lilo.conf) but I am still getting INIT output. I just need to stop that now (I can live with the odd kernel message for now).


All times are GMT -5. The time now is 10:03 AM.