LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-29-2009, 08:28 AM   #1
Mr.Digimon
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Rep: Reputation: 15
"Signal out of range"


Here we are once again with an error....
Well i just bought a new nvidia card to my computer to get the Linux games to work (MSI geforce 7600GT), but when i start the games the monitor goes black and a message displays "Signal out of range", I've tried to search on the net for a solution but what I've found it seems to be something with the resolution/refresh rate.

I got a LG flatron L1811S monitor, the max resolution is 1280x 1024 and highest refresh rate is 85hz, but i run the backport of KDE 4.1 on Debian Lenny and the control panel only allows 54hz as highest.
I read on the net and it says that the control panel takes its information from Xorg, but i haven't found the right commands to add new refresh rates....

Do you guys know how to fix this?

To do:
-write into Xorg new refresh rates
-make sure the rates work

i got the newest drivers provided by apt, and everything is recently updated.

Here is my Xorg:
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"se"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"NVIDIA geforce 7600GT"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"L1811S"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA geforce 7600GT"
	Monitor		"L1811S"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024_80" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024_80" "1280x1024""1280x1024""1280x1024""1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024_80" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024_80" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024_80" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024_80" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
It didnt work to add _80 after the resolutions as some sites claimed that would work.....

If you need some more info so ask....
 
Old 01-29-2009, 09:33 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Fedora38
Posts: 6,147

Rep: Reputation: 435Reputation: 435Reputation: 435Reputation: 435Reputation: 435
Get rid of theose "1280x1024_80" bits.
Otherwise it looks OK but you need to
add entries for Horix & Vert rates:

Code:
Section "Monitor"
	Identifier	"L1811S"
        HorizSync       50.0 - 75.0
        VertRefresh     50.0 - 75.0
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA geforce 7600GT"
	Monitor		"L1811S"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024""1280x1024""1280x1024""1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection
Then restart X.
Any better?
 
Old 01-29-2009, 01:31 PM   #3
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
You might want to install nvidia-settings and nvidia-xconfig from Debian testing repository. I can't remember which one worked for me.
 
Old 01-30-2009, 07:30 AM   #4
Mr.Digimon
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Thank you, i'll try this right away!
 
Old 01-30-2009, 07:55 AM   #5
Mr.Digimon
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 15
No luck....i did as you said and removed the _80 and added the sync rates....
still maximum allowed at KDE is 54hz.
here is the xrandr report:
Code:
Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      50.0*    54.0
   1024x768       51.0     59.0     60.0
   800x600        52.0     65.0     66.0     67.0     68.0     69.0
   640x480        53.0     74.0     75.0     76.0
   1280x960       55.0
   1280x800       56.0
   1280x768       57.0
   1152x864       58.0
   960x600        61.0
   896x672        62.0
   840x525        63.0
   832x624        64.0
   800x512        70.0
   720x450        71.0
   640x512        72.0     73.0
   640x400        77.0
   640x384        78.0
   576x432        79.0
   512x384        80.0     81.0     82.0
   416x312        83.0
   400x300        84.0     85.0     86.0     87.0
   320x240        88.0     89.0     90.0
still i cant get higher rate at 1280x1024, but even weirder is that my screen says that im running 60hz tho KDE say 50hz....

EDIT: Is it possible if i add higher resolution that the rate will go up?

Last edited by Mr.Digimon; 01-30-2009 at 08:07 AM. Reason: Forgot to ask something.....
 
Old 01-30-2009, 09:19 AM   #6
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,249
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
The MAX refresh rate of a monitor is NOT the MAX refresh rate of a monitor at it's highest resolution, this is a common misconception.
Yes your display may support up to 85Hz refresh rate but probably at a much lower reolution. The higher the resolution the lower the functional refresh rate usually drops.

If your displayi is handling 1280x1024 @ 60Hz, then you have probably hit the max capability of your display.

Did you look in your Xorg.0.log, to see what rates, were automatically detected for your display ?

Code:
before xf86InitialConfiguration
(II) RADEON(0): EDID vendor "DEL", prod id 61442
(II) RADEON(0): Using hsync ranges from config file
(II) RADEON(0): Using vrefresh ranges from config file
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) RADEON(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) RADEON(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) RADEON(0): Modeline "640x480"x0.0   25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) RADEON(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) RADEON(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0   78.80  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.1 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) RADEON(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) RADEON(0): Modeline "880x704"x60.7   50.50  880 920 1008 1136  704 707 714 732 -hsync +vsync (44.5 kHz)
(II) RADEON(0): Modeline "1272x795"x60.8   84.00  1272 1344 1472 1672  795 798 808 826 -hsync +vsync (50.2 kHz)
(II) RADEON(0): Output: VGA-0, Detected Monitor Type: 1
(II) RADEON(0): EDID data from the display on output: VGA-0 ----------------------
(II) RADEON(0): Manufacturer: DEL  Model: f002  Serial#: 809850444
(II) RADEON(0): Year: 2006  Week: 51

(II) RADEON(0): Supported VESA Video Modes:
(II) RADEON(0): 720x400@70Hz
(II) RADEON(0): 640x480@60Hz
(II) RADEON(0): 640x480@75Hz
(II) RADEON(0): 800x600@60Hz
(II) RADEON(0): 800x600@75Hz
(II) RADEON(0): 1024x768@60Hz
(II) RADEON(0): 1024x768@75Hz
(II) RADEON(0): 1280x1024@75Hz
(II) RADEON(0): Manufacturer's mask: 71
it looks to me like xrandr doesnt believe your display can handle that high of a refresh at that reolution either, or it would have listed it on that line, notice how mine lists 60 and 75 at 1280x1024, which corresponds to what was detected by EDID.

Code:
user@it-lenny:~$ xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1600 x 1200
VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 380mm x 305mm
   1280x1024      60.0*+   75.0     60.0* 
   1600x1024      60.0  
   1400x1050      60.0  
   1440x900       60.2  
   1280x960       60.0  
   1280x800       60.0  
   1272x795       60.8  
   1152x864       75.0  
   1280x768       60.0  
   1024x768       75.1     75.0     70.1     60.0  
   880x704        60.7  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     75.0     60.0     59.9  
   720x400        70.1
 
Old 01-31-2009, 08:46 AM   #7
Mr.Digimon
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 15
The Xorg.0.log doesnt say anything about rates, im using the nvidia driver and that is the vesa output.
I tried switching my monitor with another we have but it still said "Signal out of range", there is something creepy going on here and i wanna know what....
 
Old 01-31-2009, 12:37 PM   #8
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301Reputation: 1301
Don't trust 'xrandr' not with nvidia drivers. As stated before, run 'nvidia-settings' as root, set your settings, then have it generate an xorg.conf. This is the best way when dealing with the cursed nvidia drivers.
 
Old 02-02-2009, 02:18 PM   #9
Mr.Digimon
LQ Newbie
 
Registered: Jan 2007
Posts: 21

Original Poster
Rep: Reputation: 15
Okay, i'll try that tomorrow...
btw, ATI drivers are far more worse than nvidia
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
switching from CRT to LCD get message "signal over range" dholling Linux - Hardware 4 03-19-2007 04:46 AM
Digimate 17" TFT with NVidia graphics - keep getting "signal out of range" vasudevadas Linux - Hardware 3 12-03-2006 07:22 PM
"Input signal out of range" where are the KDE settings stored? whoisdon Linux - Software 1 10-18-2006 01:44 AM
malignant "Signal Out of Range" in FC5 Sunji.roaoul Linux - Hardware 8 05-17-2006 02:55 AM
9.2 error message "Signal frequency is out of range" ? What to do? A6Quattro SUSE / openSUSE 8 09-30-2005 09:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration