-   Linux - Software (
-   -   Signal 11 error dialogs (

linus321 05-18-2005 08:30 AM

Signal 11 error dialogs
I keep getting a "ksplash" signal 11 error, and then when I open other programs I get "kconsole", etc. signal 11 errors. I can run these programs, use them just fine, just keep getting error messages. Everything was working fine, but I updated my XF86Config file for dual monitors, which are working now, and then I got lots of signal 11 errors. Anyone have any clue???

rjlee 05-19-2005 03:13 PM

A SIG11 (SIGSEGV) fault is caused when a program accesses a virtual memory address to which no actual memory is mapped (for that program) i.e. it tries to read or write to a part of RAM that it shouldn't.

This is likely to be a problem with your X drivers, as these are used by all X programs and configured by XF86Config.

Does this problem occur for non-KDE programs (eg. Firefox)? If not, then it could be a KDE issue; try renaming your ~/.kde directory (hidden directory in your home folder) then logging in again; this often fixes KDE crash issues.

linus321 05-20-2005 07:51 AM

Thanks for the tip. I haven't fixed everything but it appears to be on the right track. The renaming the .kde directory didn't work, but I did log out and logged in as a different user and the dual monitors worked fine and no error messages either - everything AOK. As the original user I still get the error messages when closing applications but other users are fine. Any more hints??

rjlee 05-22-2005 10:03 AM

Check the output of /var/log/XFree86.0.log (or XOrg.0.log) and /var/log/messages

linus321 05-23-2005 09:54 AM

The messages file didn't appear to have anything interesting. The /var/log/XFree86.0.log had the following error:

Failed initialization GLX Extension (NVIDIA X driver not found)

Certainly explains a lot, but I'm not sure how this could have happened. Is something in a user account causing the driver not to be found? The other accout I've tried is still working perfectly. In any event, I'll look into the differences into the accounts, if anyone, and big thanks to RJLEE, knows a fix, I'd appreciate it. Thanks again.

rjlee 05-28-2005 07:24 AM


Originally posted by linus321
Failed initialization GLX Extension (NVIDIA X driver not found)
There are two drivers available for NVidia cards. The open-source version (nv) that ships with X should work fine stand-alone, but there is also a gratis, closed-source driver (nvidia) available from (see many, many posts in the hardware forum). The latter supports 3D acceleration, while the former currently does not.

I'm guessing that you don't have the nvidia driver installed, but your system is trying to use it anyway. You might try installing it (note that you will need to install your kernel sources first, and possibly run make oldconfig in the kernel directory).

All times are GMT -5. The time now is 02:21 PM.