-   Linux - Software (
-   -   Shutdown/reboot option in KDE??? (

coolamit78 10-06-2003 07:48 PM

Shutdown/reboot option in KDE???

I was using KDE for the first time in RH9 and noticed that there is no option for shutdown/reboot!

All I saw was the 'logout' option when I clicked the Red Hat Menu button. So whenever I need to shutdown or reboot, first I log out and then click shutdown/reboot at the login prompt!

Is this the same with every RH 9 box or its only I who's having this issue?



sandy 10-06-2003 07:50 PM

same here .. hmmm may be some security issues ..

Timeturtle 10-06-2003 09:40 PM

Ive noticed this myself, its kind of a pain. What I do to get around it is when ever I want to restart or shutdown, I just go to a command prompt and type:


and it will instantly start the shutdown or restart sequences. Its kind of handy, untill I can figure out how to do it in the menu's.

nebur 10-06-2003 09:53 PM

Well, i got this problem too but it's really easy to fix. All you have to do is uninstall the GDM login screen and install KDM login screen. Then, when you restart the X session it will crash, then just login in text mode and go to /etc/X11 and run the script prefdm

That's all ;)

Well, at least it worked for me... i hope it works for you.

Viva Mexico!!! :D :D :D

megaspaz 10-06-2003 09:53 PM

in kde, click the kde control center icon.
expand the System Administration category on the left.
click the sub category, Login Manager
click the Administrator mode button on the right screen
click the sessions tab
in the Allow Shutdown frame for the Console label, choose everybody.

everybody should now have the options to shutdown or reboot.

note this is for if kde and kdm is your default desktop environment. if you're using gdm, you'll have to tell linux to use kdm or something.

coolamit78 10-07-2003 05:20 AM

I found a better and easy way to solve my issue....


No Shutdown/Reboot button in KDE

My Solution

1. I right click the Red Hat Main menu button and click on 'Configure Menu'.

2. I add 2 menu buttons and name them 'Shutdown' and 'Reboot'

----> For 'shutdown', i enter either of these commands
'halt' or
'init 0' or
'shutdown -g0'

-----> For 'Reboot', I enter either of these commands
'reboot' or
'init 6'

3. Optionally, one may choose an icon for the shutdown and reboot buttons.

and there you go.....problem solved! ....

Thanx so much for the help friends :)



All times are GMT -5. The time now is 04:53 AM.