-   Linux - Software (
-   -   Setting up X in Slackware 8.1 (

pow2k2 02-07-2003 10:30 PM

Setting up X in Slackware 8.1
I can't seem to get X to work properly. It says that there are 'no screens found'. I ran XF86config, manually put in the paramaters for my ViewSonic G90fb monitor, and it doesn't seem to want to set my geforce3 properly. I tried to manually edit the config, and set the driver to 'nv' and it still won't work. Anyone know how to fix this?


neo77777 02-08-2003 11:19 AM

Well the way I did it when I first set up Slackware was w/o X I set up my internet connection, through lynx I went to NVIDIA site and downloaded the tarballs for NVIDIA drivers, then I ran xf86cfg this is the tool to set up XFree86 4.x, I saw an ugly highest resolution screen my card and monitor can handle (1600x1200), ctrl-backspace'd out of X, and compiled the NVIDIA drivers, edited the /etc/X11/XF86Config according to NVIDIA instructions, and then startx'd to get to X.

pow2k2 02-08-2003 04:57 PM

ok. I'll do that. thanks.

restless 02-08-2003 07:00 PM

i've had some problems with it too recently...
what i've done was this... when you start xf86config and he asks for the horizontal resolution go and look in your book of your monitor what EXACT hor. freq it has at f.e. 1024 and what EXACT vert freq it has 768, for me it was something like 67.4 and 85...

then when he asks if the resolution modes a good just edit it... and set it only to 1024*768, i think it's the 3rd choice...

when he asks for a 3d card if your card isn't in the list choose 0, set your ram and give it a name... don't try the geforce, just use a standard vesa (i think, i know it's 0) and if you've done all this try to start x, this should work now...

pow2k2 02-08-2003 10:22 PM


I setup my internet connection, and I downloaded the latest nvidia drivers. Now when I try 'startx' , the screen shows the nvidia logo, and then it gives me this:


(==) Log file: "/var/log/XFree86.0.log", Time: Sat Feb 8 22:13:21 2003
(==) Using config file: "/etc/X11/XF86Config"
(II) [GLX]: Initializing GLX extension
(EE) xf85OpenSerial: Cannot open device /dev/mouse
      No such device.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
No core pointer

Fatal server error:
failed to initialize core devices

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

I have a M$ wheelmouse optical plugged into the PS/2 port. Any idea how to fix this?

restless 02-09-2003 06:40 AM

what did you enter with the xf86config??? did you enter a special microsoft mouse pointer, or did you just enter PS/2 ?
this is another xfree problem...

simbolo 02-09-2003 10:32 AM

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "imps/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZaxisMapping" "4 5"

try this in your mouse section of you XF86Config, edit #of buttons and what not, if its usb try:
Option "Device" "/dev/input/mice"
ps2 mouse use: Option "Device" "/dev/psaux"
as /dev/mouse is just a link to one of those two

N_A_J_M 02-09-2003 03:32 PM

if you have a usb mouse edit your /etc/X11/XF86Config file
and change the protocol to "IMPS/2"

also edit the /etc/rc.d/rc.modules file and uncomment the required usb stuff, ie: usb support for ohci and so forth
also ensure you have support for usb mice enabled
this tells your kernel to enable support for usb.

im guessing when you setup slack you just used the default kernel?

pow2k2 02-10-2003 05:39 PM

I got it working... I ended updating the kernel to 2.4.20, and configured it for USB HID. Everything works great now.

All times are GMT -5. The time now is 09:17 PM.